Diablo Immortal stuck "Updating" in Battle net

Starting yesterday afternoon, my Battle net is just stuck at 0% “Updating” and I am unable to launch and play Diablo Immortal.

Steps taken to troubleshoot and resolve –

  1. closed and relaunched Battle net – did not resolve
  2. ran Scan and Repair – did not resolve / said there was nothing to repair
  3. restarted PC – did not resolve
  4. completely uninstalled and reinstalled – resolved (after a 3 hour install which caused me to miss Assembly and Shadow Wars).

Today (after shutting off PC overnight), the problem is occurring again. It is not a feasible solution to have to completely uninstall and reinstall the game every day / every PC reboot.

Another thread mentioned updating nvidia drivers; however, mine are fully up to date, so that’s not the same problem.

6 Likes

Having exactly the same issue. Having to reinstall the game every time I want to play is rediculous. Just started yesterday for me. I really hope this gets fixed soon.

2 Likes

i am having this issue as well it seems. stuck at 99% updating. ive stopped it twice uninstalled and reinstalled. third time i left over night. will not complete installation.

1 Like

I have reinstalled the game 8 times since they sent out the mouse cursor and full screen update, now i stay on updating 0% and only way to fix it is by reinstalling it on battle net pc app im losing my cool on this because it even made me miss Rite of Exile.

2 Likes

Same problem - I’m stuck on “Applying Updates” and it never actually moves to d/l the update. Drivers are up to date.

1 Like

I lowkey kind actually really hate the mouse cursor/full screen update. At least, without the option of borderless window. I’m constantly having to fight with the app to multitask – having to alt-tab to get out of the game over to my browser, or discord, or whatever else. The app likes to grab control of my cursor constantly, and it’s a big pain. Would have rather them have left it the way it was.

yeah, I have the same problem. After updating, I’ve just started not seeing some of NPCs in the game. For example I cannot see bounty leader and so I cannot get and complete the daily tasks. Furthermore, I cannot see Identifier in the big city and more and more…

@armyhutch it legit is all bad… i love this game but this is starting to draw the line on wildness! as i sit and reply this will be reinstall #16

Have the same issue.
Turned off firewall and virus protection.
Uninstalled Battle.net
Cleared the Cache folder in
C:\ProgramData\Blizzard Entertainment\Battle.net
Reinstalled Battle.net.
Reinstalled Diablo Immortal.
Still was stuck at “Applying updates 0%”
Switched to Battle.net Beta to see if that might help and it did not.

Hello everyone,

This is usually caused by a permission issue or security program. For the Battle.net app, please uninstall then make sure to reinstall it in its default install location in C:.

Closing background programs can help but sometimes it’s not enough, you should temporarily uninstall any anti-virus, anti-spyware, adware programs if using any.

That’s not really a viable solution for me. I have my C: drive partitioned for the OS and it’s dedicated to that function. The rest of my SSD is partitioned separately into my D: drive which is where everything else lives. I’ve done this for decades, and I’ve never had any problem with any program or game.

You can keep your games on your D:\ drive. Just the App would need to be installed on C:\

This did not work. My diablo 3 have no problem but only diablo immortal. It started yesterday. If you said that it is permission issue or security program is the problem then why Diablo immortal is only the ones affected and not Diablo 3.

So, unsurprisingly, having it on my C: drive did not change anything.

It wasn’t like this at launch, and it’s not impacting any other games, or any other company’s game launcher. It’s unique to Diablo Immortal, and it wasn’t happening at launch. It only started happening after the patch before I made this post.

i m sorry but this doesn’t work either
i did reinstall Battlenet app in C:/, and i did disable all the antivirus etc programs
It worked once, but now the same procedure is not working now
The Game runs fine on mobile, i cant understand though what is going wrong on PC

This is happening for me as well I have tried on three different computers just to see if it was something with my registry or what not but no same result. (and tried every suggestion and step mentioned in the thread) I spend far too much money on this game to remain interested if I can’t get into my “shadow war” because of an update that isn’t there.

This topic was automatically closed after 30 days. New replies are no longer allowed.