Diablo Immortal stuck "Updating" in Battle net

The last thread about this got closed recently.

Just want to say that this issue still persists. Diablo Immortal started an update and gets stuck at “initializing” . The only way around this is to completely delete the Diablo Immortal folder and reinstall the game from scratch.

None of the suggestions mentioned in the last thread worked other than the above.

5 Likes

same here. I only can use my Android to play this.

Same here.Havent worked all today.

Same here, i removed it and installing right now. Hope it will work.
Edit: Reinstalling worked.

This sounds like there’s some kind of permission issue going on. These two things might help:

  1. Ensure that the Battle.net App is installed on C:\
  2. Create a new Admin account and try patching through that

Reloaded battle.net.Didnt help,still initializing.Still same thing.

Same problem here. Stuck on initializing at 99%.

Same here. Permissions suggestions did nothing

Been 24h now,still dont work.Good job Blizz-

Hi Everyone,

Same issue here. Other gemse like Diabli III or Starcraft can be updated so this is effected only Diablo Immortal sounds not like a permission issue. Sounds like a patch issue what really should solve. Quite wierd that much ppl react here, and no solution.

trying this suggestion. cross fingers

Also happening to me. Game just crashed /shut itself down completely out of the blue and now it needs to be updated. Reinstalling it seems to work, but I don’t have the time to this over and over again.
Pls fix this.

same thing here , today is the 3 time i have to desinstall game and install again…still no solution and no word from Blizz …and we are going off Beta ( looks like we are in Alpha still )

1 Like

same problem here… able to download and update other blizz games, just not Diablo Immortal. I’ve uninstalled and reinstalled several times now, I normally get to about 90% and then everything just comes to a halt.

I’m having the same problem. I’m now having to reinstall for the second time in two days. I’m getting so tired of the constant problems with this game.

This does nothing. Can you please bring this bug to the attention of the developers or whoever can recreate and fix this issue? Every bug like this always effects me. I’m perpetually getting screwed over.

some thing again i have to delete and re-install this is rubbish again …blizzard get yer finger out your umm !

I did not have this problem until the last windows 10 update and the last 2 diablo immortal updates. This is the 2nd time in 2 weeks, I have had to uninstall/install the game.