I can't download second map (westmarch)

Hello!

First of all I am impressed with th amazing game.
Sadly every time I try to download the second map (Westmarch) it keeps crashing at 74%
I already tried repairing the game (8times?) But every time it keeps crashing.
It tells me I need a internet connection to continue. Which I have and never continue past the 74%

I really would like to continue playing!

Anyone got tips?

3 Likes

Hello Wobbely,

If the download is still crashing, please ensure your device has enough disk space. You can try to move the game from the internal SD card to an external one or the other way around.

Check if there’s any data restriction for the apps in your phone’s settings or try switching to a wifi connection instead.

Same problem here, got a iphone 11 20gb free space, on a connection with 1000mb’s and still not downloading.
it wont even start

3 Likes

Google pixel 3, 20gb of spare storage.
I am Experience the same problem. Downloads won’t start and a error message pops up saying I need xx space on my device before trying again. Have run the repair agent a few times with no success.

1 Like

Any updates on this? I have the same issue and have enough space for this download

1 Like

Hi same here but with Zavain map. Everytime I try downloading it, it gives me “connection lost, check your Internet” every single time it reaches 23.8%, however any other map downloads just fine and I can play fine. There is more than enough space for the map as well, the issue is specific to the Zavain map only.

1 Like

I have also the same issue to download a map.
“Sea of Shassar”…

Enough Disk Space, re install, repair… It’s stuck all time only on this part. I ca t continue the game now. :frowning:

Having the same issue for this map as well.:thinking::thinking:

1 Like

Complete uninstall and uninterrupted reinstall with all optional content fixed it.

2 Likes

This was helpful.

Complete uninstal, reinstall Apk and download the content.

It’s working…

1 Like

I have tried uninstalling and reinstalling. I have 12MB free and can not download any additional content. Too bad. It’s a great game but the bugs ruin it.