Teleport and shops dont work

When i try to teleport, the port only come, and nothing happens…
And when i try to use the shops i disconnect…

At last - someone else with my problems.

I click on a shop, I get the shop loading animation, it taps there for a long time, then says “connection error” and restart the game. I have tried on numerous different connections now and it’s not my end. All shops in game are like this for me - hilts, crests, runes etc

With teleport, it uses the animation and then just sits there with the portal open. I go nowhere. Nothing can attack me whilst I’m ‘in’ the portal. But I also don’t change zones. I can’t go to my warband camp because I can’t get out of it.

1 Like

Ok, I fixed it!

I completely removed the game from all my devices. Then fully re-installed it - and now everything works exactly as normal.

I had done this before… but maybe there was some issue with the download or other that wasn’t working… at any rate, it’s now fixed.

My Fiancée and I have been having the exact same issues as you had. Thanks for posting how you were able to resolve your issues.