EU Servers: cannot join a friend's game

i have same Problem ! what the hell???

Cant create or join games what is wrong?

But it is. Totally random where can i join. Fix it. This is joke what you do with servers.

Message - this game is no longer available.
just why???

Same here nothing works

Hi all,

This is likely going to be a result of the rate limiting described in this post:

I realize it’s a frustrating situation and hopefully with some of the incoming improvements mentioned in that thread issues like this can be alleviated over time.

Dear Tyrskon,
it is different problem.
Something new occurrs today.
Yesterday I was able to connect for trade. and to play (jsut wait sometime from previous attempt connection)
Today I cannot connect to a game by known game name or using Join option in FriendList.
These are absolutely different symptoms.


They added new servers on EU and NA. Now, if you are on an other server like your friend, you cant join.
GG Blizzard, good work, like always.

Hey OrgrimNinja,

Thanks for the reply and additional info!

We’ve passed the reports along to see if there is something else needed to address this.

1 Like

Same here. If i try connect friend, game show me error message. After the error message i cannot create lobby or solo game too.

its not its split servers by diff IP’s and you cant join other IP.

how do i know this and you dont?

Joined a few baalruns to a friend by typing game (yeah, that even worked today), after a few runs i switched to join by friendlist (yeah that worked too - impressive!) then he crashed and it wasnt possible to follow him to created games.

nice job there.

If you use TCPView and check what server you are on when it doesn’t work

Just make an outbound rule in windows firewall for that server address (block it) and you will be able to join.

It worked for me

adress for server are as follow:
North America






Credit to reddit:


Update to this here:

Hey all,

We’ve seen some reports of this happening and from what the devs say, it happens when we’re actively deploying something server-side like a fix, which is why it happens to several players in spikes when it happens. The issue will usually resolve itself if both friends restart the game client, unless the deployment is still actively happening. Alternately, you can wait for the deployment to finish and it’ll clear up on its own.

I know that this is not exactly optimal when queues are active, so here’s an alternate work around. Other players mention that temporarily removing each other from their friends list can work around this. Just make sure that there’s a way to re add each other once you finish.

Either way the developers are working on needing these fixes to happen less often over time which should prevent the problem from popping up less often over time as well.

thanks for the workaround, work flawlessly

It still not working for me and my friend :frowning:

this was 20 days ago!!!

Ive got the same cant play cant see they are online… playing the game

Same issue. We are both on Europe server, same game name but we see two different thing. He is alone in the game , where as I am with another guy with the same game name on the same server , on the same difficulty at the same time.

It’s been 12 hours.

Tried relogging, changing realms etc. Still can’t connect.

Getting the message “This game is no longer available to join” when trying to join games.