Can't select Battlegrounds from main menu

Returned after a long break. Every other game mode and button in game seems to work fine but when I select Battlegrounds from the main menu nothing happens. It does the animation the button has been pressed and gives the mouseover text but nothing else.

Using a Pixelbook Go i7

Can you try working through the steps here.

Cheers for your reply but unfortunately those steps didn’t solve it.

If it helps I’m using ChromeOS not Windows and the app isn’t available for this device in the Play store in order to try a app repair.

This device is fully updated and has no installed antivirus.

I’m in sort of the same situation, back on Americas region after a long break, but I cannot select any game modes. Three top buttons dont work and the one for BG/Arena/Solo/Duels is not even showing.

However, everything works fine on Europe and Asia regions. Maybe the same for you?

I was already using the EU server but what resolved it for me was to use a different device (I used my Xiaomi phone) which was able to click the button. This worked on the Battlegrounds button as well as that new Mercenaries button which did not originally work either on my Pixelbook Go laptop. I played through the first few missions of each on my phone then logged back in on my laptop and it worked. Hopefully the same works for you mate.

edit: thinking about it, I really think “Try a different device” or something to that nature should be added to to page of ‘try these things first’ reasons. Would have at least worked for me :slight_smile: