Mercenaries button dont work

hi i cant play mercenaries when push the button ( mercenaries with new on top) nothing happen i re install the game but nothing

Seeing the same thing. The Mercenaries button is lit up, but no response when clicked. Playing on PC.

so how u fix it…? should we waite till next update?

I have a similar problem: Button is “greyed out” and when I click on it, the text ‘new mode coming soon’ reads.
Very unfortunately, I was really looking forward to enjoy playing it on mobile.

same to me…same to me…same to me…same to me…same to me…

same problem here …

1 Like

same issue :frowning: playing on PC

Hello,

Thanks for the reports!

We’ve passed this along for further investigation. For now, could those who are able try to complete the intro tutorial on a mobile device and then give it another try on PC?

Much appreciated and let us know how you get on!

2 Likes

Hi, i try it on my tablet, but its the same :sleepy:

I had the same issue, I did finish the tutorial on phone and problem solved .

I am using an Acer Chromebook, and I have the same issue: the “mercenaries” button is highlighted on the main screen, but when I click on it I hear the “button click” sound but nothing happens. The rest of the game is unaffected as I can still play battlegrounds, standard mode, etc.

Any ideas on a fix for this?

EDIT: fixed the issue by logging onto my account on my mobile and running the first Mercenary missions on that. Once I had completed the tutorial missions the game then worked fully on my chromebook too. :slight_smile:

No matter how often i press the mercenaries button, nothing happens

I cannot even get the homepage for Hearthstone to select the Mercenaries button (greyed out or not) Installed the game for the first time 4 days ago to get the WoW Sarge mount. When I click Play it directly takes me to a game, no tutorial, nothing. Tried uninstalling and re-installing but same issue. If I should report this in another thread please advise, cuz I haven’t been able to find it. Thanks!

Hello everyone,
I have downloaded the newest update and trying to play with the “Mercenaries” game mode.
Unfortunelly it never starts. I reloaded 10-15 Times in a row, but with no results.
Could you please help?