Mercenaries: Can't open packs

For some reason I am unable to finish the mercenaries tutorial. Tutorial 2: We’re Hiring doesn’t offer me to build the Mercenary Cart. As a result my Mercenary packs are locked, I can’t open them!?


I am having the same issue

Me too:-( Cant build Mercenary Cart, cant finish tutorial…

This needs more awareness, you are not alone in this issue, im having the same issue.
People in the following post are also having this issue.

1 Like

Here the same, i have this issue too

Here with the same issue… can’t open any pack even after purchase in the shop

Does it say you need to complete the Tutorial first?

On the task board in the village, click on Tutorial 1 that you’ve completed, and then click Claim.

You’ll be prompted to build the Merchant Cart. Then you can open the packs

There is nothing to claim, it is not blue. The quest is: “Tutorial 2: We’re Hiring”, however the Mercenary Cart cannot be built, it is not available.

I just built it, and I’m able to open Mercenary packs. Check the building menu to see what you need to do to unlock it. I think you need to claim a few more bounties

In the workshop 2 out of 3 are done and have a check mark:

  • Tavern: Fully Upgraded!
  • Travel Point: Fully Upgraded!
  • Campfire: Gain an additional visitor slot, complete 25 mercenary tasks (currently 5/25), this is not part of the tutorial.

The option to build a Mercenary Cart is not given, so the quest Tutorial 2: We’re Hiring! cannot be completed.


You only need to complete Tutorial 1.
I’ll check again to see how I unlocked it. It just prompted the construction of the Merchant Cart.

Edit: Apparently. the bug occurs if you have completed the second bounty without building the merchant cart first.
Hmm…I’m sure they’ll patch it soon.

I’m having the same problem. Hopefully, they’ll fix it soon.

I have the same problem

Same issue. Need fix.

I think this is regional. With the same account, same game version, i have successfully completed the tutorial, built the Cart and was able to open the packs in Americas region. if i switch to Europe, i cannot complete the tutorial

I am unable to complete the quest on Americas. The region does not seem to matter.

Most likely it matters in what order you (and the rest of us) went through the questline. Not building the cart at the very first opportunity to do so, makes it impossible to be built later on.

I’m requesting a refund for the packs I have purchased (with money. not in-game gold). If enough of us do so, it may speed up the fixing process…

Edit: it seems the issue has been officially acknowledged: “(Updated 10/13): We are investigating an issue with players getting stuck in the Mercenaries tutorial. *Update: There were two separate, but related issues with the tutorial. Today’s hotfix resolves one of the issues. We are continuing to work on the other issue.”

Thanks for sharing the link, Self! Just adding some blue for visibility:

As always if you run into any other issues that aren’t already listed, feel free to check for existing threads and add your own report here:

I am also unable to build cart and open packs :frowning_face:

1 Like

Finally solved. Thanks go to the devs. ! :slight_smile:

it isn’t solved. I can’t open packs, adn I have done Tutorial 1.