Play botton didnt work


when i push the play botton didnt work in the new adventure, can anybody help me? is the 1 heroic boss of the new adventure


Hey Superines,

Are you able to log into Hearthstone at all? Are you playing on a computer/mac or handheld device?

Have a few seconds to spare? Let me know how I’m doing!


i can log and play all except this boss , the play botton is frozen so i cant continue playing in heroic mode, i try to play in pc windows and on mobile , the same error. I have reinstalled game and have restarted cache dates, but it didnt work, can help?


I have kinda the same problem. I can play HS fine but the play button in the solo adventure doesn’t launch anything. I can click the leave button. And also the hero picture doesn’t appear in the bottom left corner. I play on IPad.


Hello, same problem here. I cant start normal mode, hero portrait isnt displayed in the left corner and instead of showing my wins for hunter, it displays shaman wins though hunter deck is selected. Heroic mode works fine. Is there any option to reset the current run in this menu?


I am having the same issue my hero picture on normal mode is gone and whenever I click the play button it dose nothing even if i leave and go back in it’s still the same but it allows me to play heroic mode.


Everything is back to normal for me.
Thanks :slight_smile: