The heist pve content is not working


Since topic was closed without any fix and the pve content is still not working I am just copy paste it … again?

I just tried to play new Dalaran heist pve content and it somehow got bugged. Boss selection screen is black and when i press play it throw me: “There was an error starting your game. Please try after few minutes and try again.” As well it is wrote 1/0 challenge (completed most likely). Tried both on PC and iOS, not working on both platform. I started play with Shaman hero on chapter 1 if this matter somehow.


I’ve got the same problem. I bought 2nd chapter and started new adventure with Shaman and I got stuck on first boss and I cant neither start over again nor just fight with the boss. Screen on the boss is black and I get the same message when I want to start to play. And I’ve got this for more than 12 hours already.


Same Here.
wanted to play first chapter with mage, 2. Heropower and the Starting deck BURN.
The FIrst Boss (1/0) shows but wit ha black background.


Having issues aswell with the PVE content. I played 4 bosses in Heroic mode, when i started at the 5th almost my entire deck was gone…


yeah this who thing is still an issue and there hasn’t been anyone with the fix for it


Same problem here…can´t play any game-mode…ranked, unranked, arena, solo…nothing works.


same here, the normal mode works fine but the heroic mode is completely bugged, i can’t start a new run and i can’t finish the current one even if concede it just restarts to the first boss, also i can’t select cards or treasures thus i can’t kill the last boss, and when i loose it restarts… i don’t get it…