Can not install the game


#1

Since the 64-bit update, i can not install the game anymore, it said “a 64-bit operating system is required to install heroes of the storm” and i have already a 64-bit os installed :), i have all my drivers up to date also my windows updates are ok. I tried to reinstall the directx also.

Any ideas?


#2

xNoMercy, when that error message appears on a 64 bit OS, it might indicate that the minimum system requirements are not met. Please, make sure that’s not your case!


Feedback? Click here! https://www.surveymonkey.com/s/Vyraneer


#3

I checked already, otherwise i wouldn’t post.

By the way i played the game for 2-3 years but after a 3-4 months break it happened.

EDIT: 14 days and still no answer, thank you support team for sending me on boards.


#4

i have the SAME PROBLEM. PLEASE HELP US !!!


#5

Good morning TouchMyBody,

I can see that you have successfully logged into the game after your post, so I am assuming, your issue is fixed.

Kind regards


What’s your opinion?

https://www.surveymonkey.com/r/Kiemmaki


#6

I still can not log in in the game guys, u solved his problem but how about me guyys?

help me, 26days and no answer :expressionless:


#7

Good morning xNoMercy,

Do you get any error message when you are trying to log in or what is happening?

Kind regards


What’s your opinion?

https://www.surveymonkey.com/r/Kiemmaki


#8

Since the 64-bit update, i can not install the game anymore, it said “a 64-bit operating system is required to install heroes of the storm” and i have already a 64-bit os installed :), i have all my drivers up to date also my windows updates are ok. I tried to reinstall the directx also.


#9

Hello again,

Could you please post a DXDiag and MSInfo here? If the data is too big to be posted on the forum directly, you can use a page like pastebin.com and post the link to it here then.

Kind regards


What’s your opinion?

https://www.surveymonkey.com/r/Kiemmaki


#10

Ok, take a look, i cannot post links even with the “hyperlynk” option so i did that.

MSInfo pastebin .com/9F88Q2vm
DXDiag pastebin .com/tZ24Bcp5


#11

Try to install the game, don’t know man maybe blizzard support can help you :-??


#12

Good morning xNoMercy,

And thanks a million for the data. Your drivers are shown as pretty much all of them being outdated. Please use only the drivers provided on the different manufacturers webpages. Your graphics cards latest driver is for example available here. Please do the same with all your other hardware.

You should also look into either updating or deinstalling the amddvr software you are running because it can cause issues as well when being outdated.

Kind regards


What’s your opinion?

https://www.surveymonkey.com/r/Kiemmaki


#13

Still doesn’t work after i uninstalled amddvr software and i updated all my drivers.


#14

Hello again,

I am sorry to hear that. Could i get a freshDXDiag and MSInfo please?

Kind regards


What’s your opinion?

https://www.surveymonkey.com/r/Kiemmaki


#15

DxDiag pastebin .com/Rv3MMgpV
MSConfig pastebin .com/TZ5P4Bic


#16

Try to buy a new PC man. GL, maybe the blizzard support guys could help u


#17

One month and still no answer, can you help me ?


#18

Hello xNoMercy,

Looking at the files, it is possible that your CPU (Intel® Xeon® E5450) can’t “access” all 64-bit specifications. These limitations often come from outdated BIOS or from outdated motherboard chipset drivers.

Unfortunately, your BIOS didn’t receive further updates since 2011, which is also the date of the version you have now. Your motherboard chipset drivers seem to date back to 2009 though - please make sure there isn’t a more recent version available on manufacturer’s website (you can either use the automatic update feature or you can look for your chipset model).



Feedback? Click here! https://www.surveymonkey.com/s/Vyraneer