Heroes game crashes


#1

So when i click the play button on hots the game starts fine but when i get in to the connecting authentication procces this thing pops up and and says Files in your hots istallation is damaged then my game crashes ive been trying to find a resolution but hots dosent have any support of any kind and my friend has the same problem but with overwatch Pelase Help


#2

Hey Villej,

If the game crashes at that stage, the installation itself could be damaged or something else could interfere while the game is running. Start by repairing the game files and close background applications before testing again.


Have a few seconds to spare? Let me know how I’m doing!
https://www.surveymonkey.com/r/Nenyasqi


#3

You are likely using Windows LTSB or Enterprise and not being updated.
LTSB doesn’t have extensive feature updates that are required to run the game or even install it properly.
Another unrelated issue could be a faulty drive you are installing it to.
If you are using an HDD for games, at least make sure they have a big enough buffer to work properly but in this day and age HDDs are only used as storage and archive.

Use SSD, cheap ones are just as good.

Make sure you updated all your drivers and your Windows is updated with at least critical updates to 1803.

If you are using LTSB then your issues will probably not improve even after updates, in Enterprise version this shouldn’t happen as 1803 is stable.


#4

Same problem here, first it seemed it was something with windows update and graphic card related, but now NVIDIA works, all drivers are updated, reinstalled hots, battlenet, scan and repair, deleted the battlenet folder, reset to default settings: nothing.
Same happened with StarCraft but it works now, so the problem is only with HotS and I have no solution, I’d like one if possible.


#5

I have the same problem, tried everything, reinstalling the game, Bnet, deleting some files in %appdata%, tried running it with and without FreeSync, scanned and repaired, reseted in-game settings, still nothing. Windows is being regularly updated, rolled back graphics driver, installed it again and even updated to newest optional version and still nothing. Last time everything worked perfectly was at the very end of Toy event and I’d really like to play it again asap