Lag spike 1-2 sec and certain times in matches


#1

Someone please try and explain me this

In QM I get the first lag spike at 00:51 and conteniue through the match

In brawl (spider tomb) I get first lag at 00:14

In brawl (volskya) I get no lags at all?

I believe this is nothing to do with any of my hardware/wifi/software but your game that is buggy!

And yes I did network test and all packages are fine!


#2

Hello Abs0lut3Zer0,

Would you mind sharing those MTRs that you ran?

Kind regards


What’s your opinion?

https://www.surveymonkey.com/r/Kiemmaki


#3

Okay, I do see some package loss now at this line (highest 3672)

et-0-0-2-br01-eqam1.as57976(dot)net - 0 | 1091 | 1091 | 26 | 153 | 3672 | 32 |

But this just happened out of the blue. I have been playing HoTs for 2 years without those spikes. Some HoTs update made this suddenly happen. Also happens outside my home.


#4

Hello again,

No, that numer is for the highest response time for a ping during the duration of the test. Data loss is the first number after the IP which is 0 in this case.

Kind regards


What’s your opinion?

https://www.surveymonkey.com/r/Kiemmaki


#5

So giving this MTR stats from a mobile hotspot (to exclude wifi issues) I see loss% of 1% from multiple IP’s

pastebin(dot)com/G6n8jXK5


#6

Hello again,

Yes, they seem to be the problem, in addition with an already bad connection response wise in the first already. A WiFi connection though is below the minimum requirement for Heroes of the Storm though and can hardly be troubleshooted. Would you be able to use a cable connection with your router at home to see if that improves anything?

Kind regards


What’s your opinion?

https://www.surveymonkey.com/r/Kiemmaki


#7

This is unfortunately not an option.
But this suddenly happened from day to day. The wifi is not the problem as my friend has been playing on the same network without having the same problem.
I also tried to play on different networks and problem persist.
It must be PC specific problem but can’t seem to point out where it fails.
I tried formatting PC and have a fresh installed Windows but problem is still there?
Any suggestions?

Also if this was network related why would it happen at specific times? It’s ALWAYS at 00:51 first time it happens

EDIT: I found some strange behaviour in HDD activity when the lag spike comes. HDD activity goes to 100% for 1-2 sec. What could cause this?

i.imgur(dot)com/Q9gVMK6.jpg


#8

Good morning again,

Regarding the connection issue, what you could try is to see if there is a newer driver for your network card available. That might help a bit.

Kind regards


What’s your opinion?

https://www.surveymonkey.com/r/Kiemmaki


#9

Just installed newest network drivers. Problem still there :frowning:

Have you any idea why the HDD spike? As I said in first post, this doesn’t happen on brawl (volskaya)


#10

Hello again,

A high usage of the SSD for a short time is not an issue and not related to your original issue at all. I am assuming you are using a MacBook, have you checked for overheating issues?

Kind regards


What’s your opinion?

https://www.surveymonkey.com/r/Kiemmaki


#11

Can you please tell me why the HDD usage spike is happening EXACTLY as the lag happens inside the game? These two things MUST be connected.

And yes, I’m using a Macbook. Just cleared all fans as well as the inside. Not a single gram of dust :slight_smile:
Also temps are running just fine


#12

I have same problem. Here is the pathping thing you ask to do it shows 300 ms.

Microsoft Windows [Version 10.0.17134.950]
© 2018 Microsoft Corporation. Kaikki oikeudet pidätetään.

C:\WINDOWS\system32>pingpath 185.60.112.157
‘pingpath’ is not recognized as an internal or external command,
operable program or batch file.

C:\WINDOWS\system32>pathping.txt 185.60.112.157
‘pathping.txt’ is not recognized as an internal or external command,
operable program or batch file.

C:\WINDOWS\system32>pathping 185.60.112.157

Tracing route to 185.60.112.157 over a maximum of 30 hops

0 Ramppelinkone.home [192.168.1.119]
1 192.168.1.1
2 * * *
Computing statistics for 25 seconds…
Source to Here This Node/Link
Hop RTT Lost/Sent = Pct Lost/Sent = Pct Address
0 Ramppelinkone.home [192.168.1.119]
0/ 100 = 0% |
1 302ms 0/ 100 = 0% 0/ 100 = 0% 192.168.1.1

Trace complete.

C:\WINDOWS\system32>


#13

Hello rensseli,

You pinged your own router, which isn’t really helpful. You have to use the IPs given in the article I linked.

Kind regards


What’s your opinion?

https://www.surveymonkey.com/r/Kiemmaki


#14

Kiemmaki

Can you answer my question above? Do you know of why it might spike at those times? It’s not randomly and It’s not happening in brawl (volskya).


#15

Hello again,

Please make sure that no other program is causing those spikes by closing background application and please also check if the cpu clock changes during those spikes as well.

Kind regards


What’s your opinion?

https://www.surveymonkey.com/r/Kiemmaki


#16

Wait how can you even tell?

Ahahahahaha! XD

This is just so funny to me!

But how in the world did he get such a high latency if this was the case?


#17

Closing background application didn’t work. Clock speed is unchanged when the activity spike hits on the HDD. It’s starting to get annoying …