Dependency data could not be loaded

So, I have annoying issue with Map editor that starded few days back (at least that’s when I first noticed that). Whenever I try to open the map I’m working on, a window pops up saying:
"
Dependency data could not be loaded

Heart of the Swarm license is needed to lead required dependencies.
Legacy of the Void license is needed to lead required dependencies.

Continue anyway? "

This happens every time I start editor (even if I was in the game seconds ago). The solution, is to log in to battle net through editor, but it is annoying to do that every time. In the past, this happened extremely rarely, and now it happens every time. Please fix this, it is rather annoying (especially that I start edditor through Battle-net app where I’m already logged in).

I’m have the same problem with the editor. And when ever I want to create a new map it only shows Wings of Liberty under Standard and is mising Heart of the Swarm and Legacy of the Void. And Custom does not have Heart of the Swarm and Legacy of the Void dependencies in Add Standard Dependencies. It only has:

  • Liberty (Mod)
  • Liberty Multi (Mod)
  • Liberty (Campaingn)
  • Liberty Story (Campaingn)
  • Warcraft III (Art Mod)
  • Nova Covert Ops (Art Mod)
  • Co-op Mission
  • Glue

In that order.

And I opened one of the files that have the Heart of the Swarm and Legacy of the Void dependencies. It messed up the terrain, the cliffs disappeared and left a hole in their place and all the high ground got flattened. Didn’t go any further and left the file.

Just had this issue AFTER patch 4.9.3 but found a solution, kinda. I hadn’t opened the editor in years and this is a fresh win10 installation (yes, greenlit in firewall already) with the latest updates as of August 2019. In my case going to “File->Manage Published…->Log In…” would save my account/email but not actually log me in, simply returning to the login prompt. Definitely connecting and using the correct password because deliberately entering incorrect nonsense would immediately give the red “incorrect password” message as expected. What fixed it for me, and this will sound incredibly stupid, is to

click on the dropdown “(Default)” BEFORE pressing “Log In…” and selecting the proper region.

Yeah, somehow the auto-detection doesn’t work. I’m EU and all other region settings I can find reflect that, game works flawlessly.

For what it’s worth I still need to re-login this way every time I restart the editor and the Preferences->Blizzard tab is absolutely worthless holding my account/email but not letting me do anything. There is no password prompt, no login button, no “save my credentials” checkbox or anything else you might expect from an account management/login tab. Well there is “check for updates on startup” but the BNet launcher does that anyway.

Gracias senor ! That fixed it !!!