No auto-login at Starcraft II

Hello DrRaqi,

Would you mind trying the following steps?

  • Open your Documents folder
  • Rename the “StarCraft II” folder to “Starcraft II Old”

After this open SC2 again directly in the European region and check if the auto login works again.

@Hawkeye and starstar, if activating the Secondary Logon service does not have any positive effect on your specific case, please also try the steps above :slight_smile:

Hello Felranys,
still only working for US.

Thanks for the update DrRaqui!

Quite an interesting situation, I would like to ask you to try another possible workaround if you don’t mind.

  • Close the Bnet app completely
  • Press Windows + R on your keyboard
  • Enter the command %localappdata% in the Run window and press Ok
  • In the window that opens up delete all folders that refer to Battle.net or Blizzard
  • Repeat the process but using %appdata% instead of %localappdata%
  • Open the Starcraft II installation folder
  • Right click on the StarCraft II.exe file and select Run as Admin

This should run the Battle.net app and prompt you with a login screen. After you are back in the app you may notice that no game is marked as installed anymore. In that case click on the Blizzard logo on the top left corner and go to Settings. In there select Game Install/Update an then press the Scan for Games button, the app should take care of everything else.

Last step, try running SC2 again in Europe… and fingers crossed :slight_smile:

bad news, still only working for us :frowning:

Thanks a million for following my suggestions DrRaqui!

I have no other workaround to suggest, this weird situation with the autologin is however being looked into already, so for now I’ll need to ask you all for your patience :slight_smile:

If any other possible workaround comes up though, we’ll do our best to update this topic promptly!

Hi.
the issue is still not fixed as for now.
Also it’s definitely not a local system issue.

Recently I visited my parents (330km away) and tried to login from my fathers laptop.
The laptop has a different OS/system (Win10 vs Win 7 ) another ISP (VDSL vs. Cable), totally different hardware (Laptop vs PC)
and yet the Login screen with US as default region came up. (that never happened before on that laptop). He also plays no games on his laptops.

Obviously the Issue is strictly/mainly server- and not client related.
I’d ask you to please acknowledge this issue the way it presents itself.
Thanks

Hey there CyrionX :slight_smile:

This issue has not been forgotten and is still being looked into, we have no ETA though.

For some players the steps posted above have restored the auto login functionalities, but that doesn’t mean that the problem is looked into only as being client side. Rest assured that all options and possibilities are considered.

1 Like

This is a problem that can be checked easily by a tester.
If you install Starcraft 2 on a new PC (with Battlenet app), when you open the game it doesn’t login automatically when you are on EU Region.
After some time on the right side of the screen an Battlenet logon screen appears and if you login there everything goes fine, but sometimes the screen doesn’t appear and you get stuck into “Connecting to Blizzard Services (The game is waiting for response from Blizzard Services …)” orange screen with 2 options: Cancel (if selected the orange screen will re-appear) and Play Offline (if selected will get an error message “Authorization Required (To enable offline play, connect to Blizzard Services to authorize your game client. …)”

Hello all :slight_smile:

Would you mind giving another shot at the auto login?

A possible fix has been applied and so far we are getting positive results, crossing fingers that will cover your specific cases as well!

Hi,
There is no change unfortunately. I haven’t tried to reinstall the game but I will try and post the result. Something changed though, a small window appears and disappears before the game is launched. I believe this didn’t show before.

1 Like

I have re-installed OS + Game. Unfortunately the auto login is still not working. This is on my desktop, I will try also on my laptop (that is a more potent hardware), but I do not think it is a hardware related issue.

1 Like

Thanks for all the updated COMARC, just wanted to drop by to confirm that I have passed already all the information to the relevant team :slight_smile:

1 Like

please fix this issue allready. its been around for over a month.
starting to get very anoying and irritating.

1 Like

also not working for me several weeks when i try to login into my sc2 account in eu. This is a joke that i cant play a game which i bought i know it is now free to play but most of us bought it and cant play it now. Fix this finally.

i agree, can you fix this problem or return all of my money, not gonna play on US server where i got nothing!

1 Like

I do not think Blizzard will take into consideration several “old-fashon” players that play an older game.
What I hope is that the services will be affected for all the games, and some fix will incidentally repair this problem.
I tried to check for a fix of this bug on my desktop, laptop and also on a Ubuntu Desktop with Lutris, but unsuccessful. All have the same behavior:
“Connecting to Blizzard Services”, unfortunately I cannot attach links with the picture of the Starcraft 2 window.

Hey all o/

I just got word that this issue should now be fully fixed as with the latest update. Please do give it another try and let us know if its working or not for you guys.

Thank you for your continued patience :slight_smile:

I have same problem…LOl and 9 days passed and they din’t fixed…

1 Like

Hello all!

As mentioned by Jingoraitin above, this issue should be fully resolved by now.

We’ll leave this topic open for now though; in case any of you is still experiencing this problem please do not hesitate in letting us know!

Hello,
The issue is not fixed for me. Still the US server is the default one and the auto-login feature is not working after log-on Battlenet client.