No auto-login at Starcraft II

Hey all o/

I just got word that this issue should now be fully fixed as with the latest update. Please do give it another try and let us know if its working or not for you guys.

Thank you for your continued patience :slight_smile:

I have same problem…LOl and 9 days passed and they din’t fixed…

2 Likes

Hello all!

As mentioned by Jingoraitin above, this issue should be fully resolved by now.

We’ll leave this topic open for now though; in case any of you is still experiencing this problem please do not hesitate in letting us know!

Hello,
The issue is not fixed for me. Still the US server is the default one and the auto-login feature is not working after log-on Battlenet client.

Hello, no one has any update for this? :upside_down_face: :thinking: :imp: :imp: :imp:

Well, tried everything from this topic. Auto login is not working anyways.

I am also having this problem, except auto login only works for America-LA, and not America-US. I hope this can be a clue to help troubleshooting.

I am on latest patch (4.12.1) and login does not work on all regions…I am stuck on “authenticating” loop - popu shows up, then it closes and asks me for password again and again. (I enter correct password, if not I am greeted by correct error message “password is incorrect”). this login loop lasts for about a week now… :frowning: had no problems on 4.12.0 before

for users on Windows Insider builds, the latest build contains this fix: “We’ve fixed an issue causing some games and applications to crash at launch or fail to install.” and that fixed the authentication issue in SC2. not sure what fix is need for those on Windows retail builds…

Getting this issue now, it was working a while ago…and i’m on Windows Insider build… Tried all fixes, just a constant loop! I doubt it’s anything to do with pfBlockNG either as the Battlenet app and Warcraft III Refrauded…i mean Reforged still work fine!

1 Like

im having this problem as well, just logged a ticket with support. very annoying !

If anyone having this issue is on Windows Insider build 20152, please switch to Dev channel and get 20175/20180, your issues will be fixed, including Halo MCC and other games that refuse to work or log in online :slight_smile:

I dont get what you just said can you please tell the instructions please?