SC2 crashes on Mac 10.15 Catalina

The game crashes as soon as I try to enter the queue - it actually forces the entire computer to force restart. This happened with the update to macOS 10.15 Catalina (never installed the beta).

It’s an iMac 2017, with Radeon Pro 580 (8GB).

Anyone else facing this? There is a sole user on Reddit having the same issue, but with a different Mac config.

Hello meelosh,

Unfortunately, Catalina as an OS is till in beta, therefore we can only recommend to roll back to the latest released version of your OS. Beta programs are not supported.

Kind regards

Kiemmaki


What’s your opinion?

https://www.surveymonkey.com/r/Kiemmaki

1 Like

I have the same issue with Catalina 10.15 and I am running iMac 2017 Radeon Pro 575 4 GB-grafik.
I have tried everything incl. advanced trouble shooting https://eu.battle.net/support/en/article/24032
It shuts down right after the loading screen…
Any tips?

Hello alexrashid,

As I said in my previous post, Catalina is still in beta status, so if our normal trouble shooting steps do not work, please roll back to the latest released version.

Kind regards

Kiemmaki


What’s your opinion?

https://www.surveymonkey.com/r/Kiemmaki

It’s not in beta anymore. macOS 10.15 Catalina has had its general release on Oct 7, 2019. This general release has been followed today’s supplemental update (which did not solve anything), build ID 19A602.

Once again, I have never installed the beta version of Catalina at any point.

I am experiencing the same as meelosh. I have also installed the supllemental update, which did not fix it… I have never run beta and I have only done the “real” updates within MacOS…

I also like to report that Starcraft 2 crashes on OS X Catalina.
In fact it just not crashes, it freezes my whole system.

3 Likes

Now it seems to work :slight_smile:
I got this: (Resetting game options, seems to have solved the issue)

First of all, please make sure that you do not have by any chance the “Lunch 32-bit client (instead of 64-bit)” selected in the Blizzard app -> Settings -> Game Settings -> StarCraft 2. If that would happen to be selected, turn this option off as Catalina does not support any 32-bit applications.

If that would not be the case, please have a look at our forum, however this time on the US region. We have a forum part there that is dedicated to the Mac support. Here is a thread from that forum about this particular problem with some possible solution from one of our players:


Give it a try with the “Reset In-Game Options” button. It is in the same menu as the previous option.

Also there is a possible solution to change the Graphic options to OpenGL in the same thread earlier: https://us.forums.blizzard.com/en/sc2/t/sc2-crashing-on-macos-catalina/3901/4

Blizzard, MacOS Catalina 10.15.1 is out and not only does SC2 crash, it actually causes my Mac to reboot. Come on guys, there is no way you did any serious testing to not see this issue.

Same here. SC2 have just made by brand new Mac Pro 2019 to reboot. Guys please fix this;

Same issue on a brand new iMac 27" retina 5k 3,7Ghz core i5 8GB of RAM with all system updates. I have also tested the hardware with Apple utility and there is no issue on hardware.
I have a kernel panic when i launch the 3rd mission with Terrans during the startup video…
Dear Blizzard team, could you please give us further informations and try to fix it ?
thanks a lot,

1 Like

Same problem…

I have this problem too. It never happens in game but always in the SC2 menu. It is a kernel panic which forces a restart of my computer (a Macbook Pro 2019).

Kernel panic details

panic(cpu 14 caller 0xffffff8001a62e0a): Kernel trap at 0xffffff7f85f68f9f, type 14=page fault, registers:
CR0: 0x000000008001003b, CR2: 0xffffff81dc214004, CR3: 0x0000000015f55000, CR4: 0x00000000003626e0
RAX: 0x0000000000000331, RBX: 0x0000000000000331, RCX: 0xffffff9227efbcc4, RDX: 0x0000000000000340
RSP: 0xffffff9227efbc78, RBP: 0xffffff9227efbc80, RSI: 0xffffff81dc213340, RDI: 0x0000000000000331
R8: 0x0000000000000001, R9: 0x0000000000000003, R10: 0x0000000000000000, R11: 0x0000000000000000
R12: 0xffffff9227efbdd8, R13: 0xffffff9214041430, R14: 0xffffff81dc213340, R15: 0xffffff9227efbde4
RFL: 0x0000000000010283, RIP: 0xffffff7f85f68f9f, CS: 0x0000000000000008, SS: 0x0000000000000010
Fault CR2: 0xffffff81dc214004, Error code: 0x0000000000000000, Fault CPU: 0xe, PL: 0, VF: 1

Backtrace (CPU 14), Frame : Return Address
0xffffff9227efb6d0 : 0xffffff8001939a3b
0xffffff9227efb720 : 0xffffff8001a70fe5
0xffffff9227efb760 : 0xffffff8001a62a5e
0xffffff9227efb7b0 : 0xffffff80018e0a40
0xffffff9227efb7d0 : 0xffffff8001939127
0xffffff9227efb8d0 : 0xffffff800193950b
0xffffff9227efb920 : 0xffffff80020d17f9
0xffffff9227efb990 : 0xffffff8001a62e0a
0xffffff9227efbb10 : 0xffffff8001a62b08
0xffffff9227efbb60 : 0xffffff80018e0a40
0xffffff9227efbb80 : 0xffffff7f85f68f9f
0xffffff9227efbc80 : 0xffffff7f85ecf419
0xffffff9227efbcf0 : 0xffffff7f85ecf1f3
0xffffff9227efbd80 : 0xffffff7f85ecaa32
0xffffff9227efbdc0 : 0xffffff7f85ecea5a
0xffffff9227efbe10 : 0xffffff7f858f3877
0xffffff9227efbe60 : 0xffffff7f85901438
0xffffff9227efbea0 : 0xffffff7f85900bf8
0xffffff9227efbee0 : 0xffffff80020401bd
0xffffff9227efbf30 : 0xffffff800203eb02
0xffffff9227efbf70 : 0xffffff800203e08c
0xffffff9227efbfa0 : 0xffffff80018e013e
Kernel Extensions in backtrace:
com.apple.iokit.IOAcceleratorFamily2(438.2.7)[72B8A0B5-E12C-3764-9187-0AC0E93416F9]@0xffffff7f858ef000->0xffffff7f859b1fff
dependency: com.apple.driver.AppleMobileFileIntegrity(1.0.5)[180FC5AB-0E47-35BC-91DF-609EBE8ED4A5]@0xffffff7f82918000
dependency: com.apple.iokit.IOPCIFamily(2.9)[AA7C7A4F-9F5D-3533-9E78-177C3B6A72BF]@0xffffff7f82310000
dependency: com.apple.iokit.IOSurface(269.6)[39DC4195-B168-3895-ACD5-E731581855F8]@0xffffff7f83d84000
dependency: com.apple.iokit.IOGraphicsFamily(568)[247C211E-C250-351C-BCE2-4DB9D3003E10]@0xffffff7f85593000
dependency: com.apple.iokit.IOReportFamily(47)[2CCA7DD3-C33F-3CA4-A213-BC83D3D997B0]@0xffffff7f82249000
com.apple.kext.AMDRadeonX4000(3.0.2)[1E092428-A3E6-3063-B692-B943B1565B91]@0xffffff7f85ec5000->0xffffff7f8630afff
dependency: com.apple.iokit.IOPCIFamily(2.9)[AA7C7A4F-9F5D-3533-9E78-177C3B6A72BF]@0xffffff7f82310000
dependency: com.apple.iokit.IOSurface(269.6)[39DC4195-B168-3895-ACD5-E731581855F8]@0xffffff7f83d84000
dependency: com.apple.iokit.IOGraphicsFamily(568)[247C211E-C250-351C-BCE2-4DB9D3003E10]@0xffffff7f85593000
dependency: com.apple.iokit.IOAcceleratorFamily2(438.2.7)[72B8A0B5-E12C-3764-9187-0AC0E93416F9]@0xffffff7f858ef000

BSD process name corresponding to current thread: kernel_task
Boot args: chunklist-security-epoch=0 -chunklist-no-rev2-dev

Mac OS version:
19B88

Kernel version:
Darwin Kernel Version 19.0.0: Thu Oct 17 16:17:15 PDT 2019; root:xnu-6153.41.3~29/RELEASE_X86_64
Kernel UUID: 7503CD47-851F-321E-8747-50DB4299165F
Kernel slide: 0x0000000001600000
Kernel text base: 0xffffff8001800000
__HIB text base: 0xffffff8001700000
System model name: MacBookPro15,1 (Mac-937A206F2EE63C01)
System shutdown begun: NO

System uptime in nanoseconds: 114631982379177
last loaded kext at 1652898624609: >!UAudio 320.49 (addr 0xffffff7f86f95000, size 434176)
loaded kexts:
@filesystems.msdosfs 1.10
@kext.AMDFramebuffer 3.0.2
@kext.AMDRadeonX4000 3.0.2
@kext.AMDRadeonServiceManager 3.0.2

!AGraphicsDevicePolicy 4.5.9
@AGDCPluginDisplayMetrics 4.5.9
@fileutil 20.036.15
!AHV 1
|IOUserEthernet 1.0.1
|IO!BSerialManager 7.0.1f1
pmtelemetry 1
AGPM 111.2.5
!APlatformEnabler 2.7.0d0
X86PlatformShim 1.0.0
!AUpstreamUserClient 3.6.8
@Dont_Steal_Mac_OS_X 7.0.0
AGDCBacklightControl 4.5.9
!A!IKBLGraphics 14.0.2
BridgeAudioCommunication 6.55
!ABacklight 180.1
ACPI_SMC_PlatformPlugin 1.0.0
@kext.AMD9500!C 3.0.2
!AThunderboltIP 3.1.3
!ATopCaseHIDEventDriver 3410.1
!AHIDALSService 1
!AMuxControl2 4.5.9
!A!ICFLGraphicsFramebuffer 14.0.2
!AAVEBridge 6.1
!A!ISlowAdaptiveClocking 4.0.0
!AMCCSControl 1.13
!ABridgeAudio!C 6.55
!AGFXHDA 100.1.422
!AFIVRDriver 4.1.0
!A!IPCHPMC 2.0.1
@filesystems.autofs 3.0
BCMWLANFirmware4355.Hashstore 1
BCMWLANFirmware4364.Hashstore 1
BCMWLANFirmware4377.Hashstore 1
!AFileSystemDriver 3.0.1
@filesystems.hfs.kext 522.0.9
@BootCache 40
@!AFSCompression.!AFSCompressionTypeDataless 1.0.0d1
@!AFSCompression.!AFSCompressionTypeZlib 1.0.0
!AVirtIO 1.0
!ABCMWLANBusInterfacePCIe 1
@filesystems.apfs 1412.41.1
@private.KextAudit 1.0
!ASmartBatteryManager 161.0.0
!AACPIButtons 6.1
!ASMBIOS 2.1
!AACPIEC 6.1
!AAPIC 1.7
$!AImage4 1
@nke.applicationfirewall 303
$TMSafetyNet 8
@!ASystemPolicy 2.0.0
|EndpointSecurity 1
!UAudio 320.49
@kext.AMDRadeonX4100HWLibs 1.0
@kext.AMDRadeonX4000HWServices 3.0.2
|IOAVB!F 800.17
!ASSE 1.0
@!AGPUWrangler 4.5.9
!ABacklightExpert 1.1.0
IOPlatformPluginLegacy 1.0.0
!AHDA!C 283.14
|IOHDA!F 283.14
!AHIDKeyboard 209
!AActuatorDriver 3410.2
!AHS!BDriver 3410.1
IO!BHIDDriver 7.0.1f1
!AMultitouchDriver 3410.2
!AInputDeviceSupport 3410.1
!ASMBusPCI 1.0.14d1
!AGraphicsControl 4.5.9
|IOAccelerator!F2 438.2.7
|IOSlowAdaptiveClocking!F 1.0.0
!ASMBus!C 1.0.18d1
X86PlatformPlugin 1.0.0
|IOAudio!F 300.2
@vecLib.kext 1.2.0
|IONDRVSupport 568
|IO!BHost!CUARTTransport 7.0.1f1
|IO!BHost!CTransport 7.0.1f1
!A!ILpssUARTv1 3.0.60
!A!ILpssUARTCommon 3.0.60
!AOnboardSerial 1.0
@kext.AMDSupport 3.0.2
@!AGraphicsDeviceControl 4.5.9
|IOGraphics!F 568
IOPlatformPlugin!F 6.0.0d8
!AThunderboltEDMSink 4.2.1
!AThunderboltDPOutAdapter 6.2.3
@plugin.IOgPTPPlugin 810.1
|IOEthernetAVB!C 1.1.0
@kext.triggers 1.0
usb.cdc.ecm 5.0.0
usb.IOUSBHostHIDDevice 1.2
usb.cdc.ncm 5.0.0
usb.cdc 5.0.0
usb.networking 5.0.0
usb.!UHostCompositeDevice 1.2
|IOSurface 269.6
@filesystems.hfs.encodings.kext 1
!ABCMWLANCore 1.0.0
mDNSOffloadUserClient 1.0.1b8
IOImageLoader 1.0.0
|IOSerial!F 11
|IO80211!FV2 1200.12.2b1
corecapture 1.0.4
|IOSkywalk!F 1
!AThunderboltPCIDownAdapter 2.5.2
!AThunderboltDPInAdapter 6.2.3
!AThunderboltDPAdapter!F 6.2.3
!AHPM 3.4.4
!A!ILpssI2C!C 3.0.60
!A!ILpssDmac 3.0.60
!A!ILpssI2C 3.0.60
!AXsanScheme 3
!AThunderboltNHI 5.8.0
|IOThunderbolt!F 7.4.6
usb.!UHostPacketFilter 1.0
usb.!UVHCIBCE 1.2
usb.!UVHCI 1.2
usb.!UVHCICommonBCE 1.0
usb.!UVHCICommon 1.0
!AEffaceableNOR 1.0
|IOUSB!F 900.4.2
|IOBufferCopy!C 1.1.0
|IOBufferCopyEngine!F 1
|IONVMe!F 2.1.0
usb.!UXHCIPCI 1.2
usb.!UXHCI 1.2
!AEFINVRAM 2.1
!AEFIRuntime 2.1
!ASMCRTC 1.0
|IOSMBus!F 1.1
|IOHID!F 2.0.0
$quarantine 4
$sandbox 300.0
@kext.!AMatch 1.0.0d1
!AKeyStore 2
!UTDM 489.41.1
|IOSCSIBlockCommandsDevice 422.0.2
!ACredentialManager 1.0
KernelRelayHost 1
!ASEPManager 1.0.1
IOSlaveProcessor 1
!AFDEKeyStore 28.30
!AEffaceable!S 1.0
!AMobileFileIntegrity 1.0.5
@kext.CoreTrust 1
|CoreAnalytics!F 1
|IOTimeSync!F 810.1
|IONetworking!F 3.4
DiskImages 493.0.0
|IO!B!F 7.0.1f1
|IO!BPacketLogger 7.0.1f1
|IOUSBMass!SDriver 157.40.7
|IOSCSIArchitectureModel!F 422.0.2
|IO!S!F 2.1
|IOUSBHost!F 1.2
usb.!UCommon 1.0
!UHostMergeProperties 1.2
!ABusPower!C 1.0
|IOReport!F 47
!AACPIPlatform 6.1
!ASMC 3.1.9
watchdog 1
|IOPCI!F 2.9
|IOACPI!F 1.4
@kec.pthread 1
@kec.Libm 1
@kec.corecrypto 1.0

In the same here, crushed and restart my Mac.
Is a Imac 27-inch, 2019 - Raden Pro 580x 8GB

Update, I Changed my Driver Card to OpenGL - https://us.forums.blizzard.com/en/sc2/t/sc2-crashing-on-macos-catalina-with-radeon-graphics/3901/4
Works for me.

Its work for me

The game crashes when I play the Protoss Prologue campaign and forces a complete reboot on my Mac. I can start the mission but I never get to do anything.

I just tried the first WOL campaign and I am able to complete it. That means the issue is on the Protoss campaign.

I am on Mac OS Catalina 10.15.1
15" MBP 2018 with Radeon 560

Experienced kernel panic on macOS 10.15.1 iMac (Retina 4K, 21.5-inch, 2019) @1440p Radeon Pro 560X 4 GB. Upon login, navigated to 1v1 and clicked Terran - the marine animation froze but the sound played. This is where the KP happened.

Reset in game settings, logged back in, adjusted resolution back to 1440p and set graphics API to OpenGL 4.1 - this resolved the issue.

An additional issue popped up now where the Zealot that’s featured when you click on Protoss in 1v1 does not have his PSI blades - just an FYI.

1 Like