SC2 crashes on Mac 10.15 Catalina

Update, I Changed my Driver Card to OpenGL - https://us.forums.blizzard.com/en/sc2/t/sc2-crashing-on-macos-catalina-with-radeon-graphics/3901/4
Works for me.

Its work for me

The game crashes when I play the Protoss Prologue campaign and forces a complete reboot on my Mac. I can start the mission but I never get to do anything.

I just tried the first WOL campaign and I am able to complete it. That means the issue is on the Protoss campaign.

I am on Mac OS Catalina 10.15.1
15" MBP 2018 with Radeon 560

Experienced kernel panic on macOS 10.15.1 iMac (Retina 4K, 21.5-inch, 2019) @1440p Radeon Pro 560X 4 GB. Upon login, navigated to 1v1 and clicked Terran - the marine animation froze but the sound played. This is where the KP happened.

Reset in game settings, logged back in, adjusted resolution back to 1440p and set graphics API to OpenGL 4.1 - this resolved the issue.

An additional issue popped up now where the Zealot that’s featured when you click on Protoss in 1v1 does not have his PSI blades - just an FYI.

1 Like

Same Problem here.

Start game witz ZvZ and after a few Minutes, the game crashes. At the secont time, the hole comuter crashes.

After that, I refresh the settings and chance to OpenGL. For know it works. Thanks Mediocrates.

im on mojave and it is crashing after today’s update!

Same here, always forces reboot in beginning of Protoss campaign ‘the infinite cycle’ on MacBook Pro 2016, macOs 10.15.1.
Before that, I had had few normal crashes usually in the end sequence of a campaign.

A different crash here. StarCraft II freezes and causes my whole system to freeze when I click on Options in the Menu. I tried resetting in game options, but it didn’t help. I’m running MacOs Catalina 10.15.2 on a 2017 MacBook Pro 13". Music still keeps playing and I can move the cursor, but the same and my whole system remains frozen on the SC2 menu screen. Option+Command+ESC doesn’t do anything. Only way to get out is to force a shut down of the computer.

Hello Xanagi,

I’m sorry to read about the situation. Regarding the issue make sure that Starcraft II is not running in the 32-bit mode (Catalina does not support 32-bit apps):
Open the Blizzard app -> Settings -> Game Settings -> StarCraft 2 -> untick “Launch 32-bit client (instead of 64-bit)” if it is enabled.

Any updates on this??? This game is now not playable for anyone buying a new 16" MacBook Pro… my current mac os version is 10.15.2 (19C57)

Hey Jeff,

If you are getting these crashes, and you already checked the 32-bit mode explained above, try first to reset the game settings:
Blizzard app -> Settings -> Game Settings -> StarCraft 2 -> Reset In-Game Options

If the issue persists there is a workaround that apparently helped other players which is to rename your system on Mac:

  1. On Mac Apple menu, go to System Preferences/Sharing
  2. Change the Computer Name to something different.
  3. Click on Edit and then Okay.
  4. Close the Preferences window.
  5. Test the game again.

Hi Shimael,
I cannot find the option to uncheck 32 bit mode but I have ‘Reset In-Game Options’. Additionally, I changed my computer name in the sharing preferences and also done a complete clean install. Sadly, none of these have worked for me.
It’s definitely not a computer issue for me as it worked for years. I stopped playing for several months and jumped back on recently only to have it 1) crash the game or 2) crash the entire computer EVERY time I play.
27’ i7 iMac, 40GB RAM, Radeon Pro 580 8GB
Any other suggestions?

Hi,
I also can’t find the 32bit setting in the menu - I only have “additional command line…”, text and spoken language and “Reset In-Game Options”.
My Starcraft2 permanently crashes during the same cutscene - I can’t play the game anymore. Sometimes it even reboots my back.
27" iMac i9, 72GB RAM, Radeon Pro 580X 8GB

Hello,

If the 32-bit option is not showing up for you it means you are set to use the 64-bit automatically so that is fine.

This issue seems to be caused by a known problem that started months ago, our team is communicating with Apple on this matter and we are awaiting for driver updates that should come with the Software Updates, for testing purposes and a resolution.

If you have time follow the US forum thread here there are few other troubleshooting steps you can try, but if nothing works I’m afraid you will need to be patient for now.

Hi just updated to Catalina today and now I can’t even open the game client and the computer is telling me to contact the developer. When can we expect an update so I can even open the game?

I updated to 10.15.3 but SCII still crashes (freeze + restart).

Same here. Looking forward to getting this solved ASAP :weary:

I have a very old MacBookPro, Mid2012. Since some OS updates SCII started crashing right away, unable to boot.
I updated several times with all the fixes created…
I lost hope and thought that maybe my Mac is too old (But Catalina is supported).
But then… I read above this:
If the issue persists there is a workaround that apparently helped other players which is to rename your system on Mac:

  1. On Mac Apple menu, go to System Preferences/Sharing
  2. Change the Computer Name to something different.
  3. Click on Edit and then Okay.
  4. Close the Preferences window.
  5. Test the game again.
    .
    AND WORKED!!!
    It is really strange this bug, but I changed my computer name in sharing and now boots fine! I am soooo happy!
    Thanks!

For anyone who hasn’t tried it, this worked for me.

Switch to OpenGL - In SC2, go to Options (Press ESC) > Graphics (Default tab) and change the Render API to Open GL 4.1 (Beta)

1 Like

This did work for me as well, but so many of the storyline mini-cinematics (like the character faces when you select a unit or in the cantina in Wings of Liberty) have little to no detail. Did you or anyone else experience this? It’s not like that when I use the Metal API (before it crashes of course).