SC2 crashes on Mac 10.15 Catalina

Hi,
I also can’t find the 32bit setting in the menu - I only have “additional command line…”, text and spoken language and “Reset In-Game Options”.
My Starcraft2 permanently crashes during the same cutscene - I can’t play the game anymore. Sometimes it even reboots my back.
27" iMac i9, 72GB RAM, Radeon Pro 580X 8GB

Hello,

If the 32-bit option is not showing up for you it means you are set to use the 64-bit automatically so that is fine.

This issue seems to be caused by a known problem that started months ago, our team is communicating with Apple on this matter and we are awaiting for driver updates that should come with the Software Updates, for testing purposes and a resolution.

If you have time follow the US forum thread here there are few other troubleshooting steps you can try, but if nothing works I’m afraid you will need to be patient for now.

1 Like

Hi just updated to Catalina today and now I can’t even open the game client and the computer is telling me to contact the developer. When can we expect an update so I can even open the game?

I updated to 10.15.3 but SCII still crashes (freeze + restart).

Same here. Looking forward to getting this solved ASAP :weary:

I have a very old MacBookPro, Mid2012. Since some OS updates SCII started crashing right away, unable to boot.
I updated several times with all the fixes created…
I lost hope and thought that maybe my Mac is too old (But Catalina is supported).
But then… I read above this:
If the issue persists there is a workaround that apparently helped other players which is to rename your system on Mac:

  1. On Mac Apple menu, go to System Preferences/Sharing
  2. Change the Computer Name to something different.
  3. Click on Edit and then Okay.
  4. Close the Preferences window.
  5. Test the game again.
    .
    AND WORKED!!!
    It is really strange this bug, but I changed my computer name in sharing and now boots fine! I am soooo happy!
    Thanks!
1 Like

For anyone who hasn’t tried it, this worked for me.

Switch to OpenGL - In SC2, go to Options (Press ESC) > Graphics (Default tab) and change the Render API to Open GL 4.1 (Beta)

2 Likes

This did work for me as well, but so many of the storyline mini-cinematics (like the character faces when you select a unit or in the cantina in Wings of Liberty) have little to no detail. Did you or anyone else experience this? It’s not like that when I use the Metal API (before it crashes of course).

Tried this idea too (after months of no use) and it worked. Thanks Zarinde!

I have the same issue. Freezes the whole machine so I have to hard reset. The game freezes on Campaign play. Not freezes on ladder games :man_shrugging:

Way to go Blizzard. Finally an update and you still haven’t manage to fix the problem!!! I cannot play the game, because it always crashes during the same cinematic scene!!!

Hi this has been reported for months now, how long is it going to take until we can play a game that we’ve paid for? You should be testing the Mac OS releases while they’re in Beta so you don’t have these issues when Apple release new software…

1 Like

Hi I can confirm changing the computer name has allowed me to start the game. What a bizarre bug?

I still have the problem. campaign or coop crashes the game. Ladder no problems !!!

I have no problem with any other game. Warcraft3 Reforged and WoW runs for hours.

Catalina 15.3. Blizzard Please fix this Bug :frowning:

panic(cpu 4 caller 0xffffff800b4652fa): Kernel trap at 0xffffff7f8fd00669, type 14=page fault, registers:
CR0: 0x000000008001003b, CR2: 0xffffff81e4938030, CR3: 0x000000001f94f000, CR4: 0x00000000003626e0
RAX: 0x000000000000044c, RBX: 0x000000000000044c, RCX: 0xffffff92316fbcc4, RDX: 0x0000000000000460
RSP: 0xffffff92316fbc78, RBP: 0xffffff92316fbc80, RSI: 0xffffff81e4936f00, RDI: 0x000000000000044c
R8: 0x0000000000000001, R9: 0x0000000000000002, R10: 0x0000000000000000, R11: 0x0000000000000000
R12: 0xffffff92316fbdd8, R13: 0xffffff921e34ca68, R14: 0xffffff81e4936f00, R15: 0xffffff92316fbde4
RFL: 0x0000000000010283, RIP: 0xffffff7f8fd00669, CS: 0x0000000000000008, SS: 0x0000000000000000
Fault CR2: 0xffffff81e4938030, Error code: 0x0000000000000000, Fault CPU: 0x4, PL: 0, VF: 1

Backtrace (CPU 4), Frame : Return Address
0xffffff92316fb6d0 : 0xffffff800b33bb2b
0xffffff92316fb720 : 0xffffff800b4734d5
0xffffff92316fb760 : 0xffffff800b464f4e
0xffffff92316fb7b0 : 0xffffff800b2e2a40
0xffffff92316fb7d0 : 0xffffff800b33b217
0xffffff92316fb8d0 : 0xffffff800b33b5fb
0xffffff92316fb920 : 0xffffff800bad2aa9
0xffffff92316fb990 : 0xffffff800b4652fa
0xffffff92316fbb10 : 0xffffff800b464ff8
0xffffff92316fbb60 : 0xffffff800b2e2a40
0xffffff92316fbb80 : 0xffffff7f8fd00669
0xffffff92316fbc80 : 0xffffff7f8fca4ced
0xffffff92316fbcf0 : 0xffffff7f8fca4ac7
0xffffff92316fbd80 : 0xffffff7f8fca01fc
0xffffff92316fbdc0 : 0xffffff7f8fca432e
0xffffff92316fbe10 : 0xffffff7f8f048877
0xffffff92316fbe60 : 0xffffff7f8f056438
0xffffff92316fbea0 : 0xffffff7f8f055bf8
0xffffff92316fbee0 : 0xffffff800ba4109d
0xffffff92316fbf30 : 0xffffff800ba3f9e2
0xffffff92316fbf70 : 0xffffff800ba3ef6c
0xffffff92316fbfa0 : 0xffffff800b2e213e
Kernel Extensions in backtrace:
com.apple.iokit.IOAcceleratorFamily2(438.3.1)[66992525-3204-3CB0-8F03-4B70031B1CF2]@0xffffff7f8f044000->0xffffff7f8f106fff
dependency: com.apple.driver.AppleMobileFileIntegrity(1.0.5)[A243D030-19AC-30AA-AC70-6C786DF9E6CE]@0xffffff7f8c422000
dependency: com.apple.iokit.IOPCIFamily(2.9)[ADD485B5-3EF8-37C4-B3C5-F86326E497A4]@0xffffff7f8bd10000
dependency: com.apple.iokit.IOSurface(269.6)[42377B3B-D14A-368E-820F-07E7EA666198]@0xffffff7f8d880000
dependency: com.apple.iokit.IOGraphicsFamily(569.4)[1F9B5D88-52DB-3A16-8373-4F608A3CB2D8]@0xffffff7f8eff3000
dependency: com.apple.iokit.IOReportFamily(47)[988360A2-2E10-3014-A119-BE81BC045A10]@0xffffff7f8bc49000
com.apple.kext.AMDRadeonX6000(3.0.5)[9CC6CB01-D968-3735-86FE-B1EDD1A96DD3]@0xffffff7f8fc9a000->0xffffff7f8fe9efff
dependency: com.apple.iokit.IOPCIFamily(2.9)[ADD485B5-3EF8-37C4-B3C5-F86326E497A4]@0xffffff7f8bd10000
dependency: com.apple.iokit.IOSurface(269.6)[42377B3B-D14A-368E-820F-07E7EA666198]@0xffffff7f8d880000
dependency: com.apple.iokit.IOGraphicsFamily(569.4)[1F9B5D88-52DB-3A16-8373-4F608A3CB2D8]@0xffffff7f8eff3000
dependency: com.apple.iokit.IOAcceleratorFamily2(438.3.1)[66992525-3204-3CB0-8F03-4B70031B1CF2]@0xffffff7f8f044000

BSD process name corresponding to current thread: kernel_task
Boot args: chunklist-security-epoch=0 -chunklist-no-rev2-dev

Mac OS version:
19D76

Hey all. I am running macOs Catalina 10.15.3. My current issue is that I cannot even UNZIP Battle.net-Setup-enUS or Starcraft-II-Setup.zip. I receive the error:

The developer of this app needs to update it to work with this version of macOS. Contact the developer for more information.

Or the Error:

Unable to expand “Starcraft-II-Setup.zip. It is an unsupported format.”

I have tried other unzipping apps like Unarchiver and receive the same error so it has nothing to do with my Mac’s ability to unzip. Thoughts? I’d rather NOT downgrade my version.

I have the same problem with 10.15.3.

It happens during the campaign, in the following cinematics:
After beating the first level of the wings of liberty campaign (the moment Thyfus comes in). If I restart the game I can actually watch the cinematic.

Clicking on the Kerrigan photo on the board shuts down my computer instantly with a panic.

The cinematic after beating level 3 also nukes my computer. The game runs fine during gameplay, it’s only during the cinematics.

This is my hardware:
Macbook Pro 15"
2,6 GHz 6-Core Intel Core i7
16 GB 2400 MHz DDR4
Radeon Pro 560X 4 GB
Intel UHD Graphics 630 1536 MB

The workaround I read above works for me too:
Switch to OpenGL - In SC2, go to Options (Press ESC) > Graphics (Default tab) and change the Render API to Open GL 4.1 (Beta)

It comes with the price of blurry faces, but otherwise I’m happy I can at least play for now.

Same here, panic immediately after click Versus. Co-Op works fine.

Same here, MacBook Pro 2016. Everything was running fine yesterday on Mojave. Crashes sometimes immediately, sometimes after a couple of seconds of multiplayer game.

Same experience. I have a maxed out iMac Pro. The game played beautifully on Mojave. Game freezes the entire system on Catalina. Such a bummer.

1 Like

Same issue here when running 2017 MBP on 10.15.4

1 Like