A bind stopped working, cant even re-assing that bind . .

Greetigns all
Here’s an interesting bug/failure/error and no idea what causes it.
So I bought a steelseries Rival 500. It was fine for like 2 weeks.
Since wow doesnt recognize more than 5 mouse buttons I macro’d all excess buttons as CTRL F1 - F8 .
Last night during playin I noticed that my mouse button 7 - aka Ctrl+F1 is no longer doing anything.
Did the uninstall/reinstall, did the 3 button pushing firmware reset stuff, still not working.
However, I changed Ctrl+F1 to => Ctrl+F9, and changed the ingame keybind for that and now works.
1 day passed, now my left tilt doesnt recognize it as Ctrl+F3 . . . Swapped for Ctrl+F12 and works fine. . .
However, I can no longer bind anything on Ctrl+F1 nor Ctrl+F3 = nothing happens if I press those combinations inside key binding settings via keyboard.
Is this a mouse error, or the game’s fault? Or is there a 3rd party I’m unaware of that could potentially cause the problem?
I’m afraid if I keep playin I’ll lose all my macro binds . . .
Tried WTF/cache deleting and running wow with 0 addons. Nothing lets me bind those specific combinations.

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.