And justice for Thrall

I tried a few more times (resetting the fight with vanish when I see Thrall is not coming) and nothing, after the stun Garrosh just attacks me infinitely while I can’t even target him.

Dam Blizzard, it’s been 3 weeks!

After dozens of attempts at different things IT WORKED
After I run a game client repair from the client!

That did it for me.


Just tried it multiple times and it’s absolutely not functioning for me.

1 Like

Retried the quest about a dozen times since my last post. Did a client repair, re-did UI reset and addon disabling again, abandoning-and-retaking the Quest, but nothing is changed. Garrosh is still stuck in his untargettable mode just attacking, while Thrall is nowhere to be seen.

All the taunts Garrosh is doing are going the burned into my memory permanently. Never thought that “I cannot be defeated” would mean “I will stop taking damage and just yell at you until my script is reset”.

Tried, did work for me.

Just tried the scan and repair option and it completed without fault

After trying a second client repair, it worked. Seems it’s just complete random, at this point.

After doing a Scan & Repair, I reattempted the quest and it worked for me as well.

Still broken for me. Trying my second scan and repair now.

Same here, still stuck in the last phase, its so annoying.

So here are steps that worked for me:

  • I did the scenario with disabled addons and Garrosh still get stuck
  • teleported to garrison and closed wow ( I did NOT abandon the quest)
  • scan and repair
  • returned to the gate and started scenario from beginning
    From the first step I saw that friendly NPCs and Durotan are more active than before. In final step I just let Garrosh talk all his lines and then slowly started to melee him, he stunned me and Thrall came, blabla, cinematic, complete.

Sorry for my english and I hope this helps


I’m going to try this now.


1 Like

Thank you so much, I did exactly how you suggested and it just worked for me!

Now that was a real quest, blizz…


Hope u will live more then 100 years :slight_smile:
Thanks, it’s realy works

1 Like

It worked for me, I thank you a 1000times. I actually had to recover my account to place a reply. But this was worth it. Thank you, you awesome person.

1 Like

worked for me too, thank you

1 Like

Thank you so much it really did work!!

1 Like

Thanks a lot!

P.S.: I did in such a way:

  1. Disable all addons
  2. Exit WoW
  3. Run Scan&Repair
  4. Run WoW, start scenario, Profit!

For those hopelessly new to the game: you run Scan & Repair by going to the Blizzard Battle net app and you find it under options (sort of top left)
I’m not sure if it actually worked yet, because I spent most of the time trying to find this.
Fun fact: you abandon the whole quest, but stay ni the area, log out, log in and you’ll find yourself at the beginning of the battle… you know the one you’ve abandoned? Some serious bug over here.

Very well, worked for us too, thank you very much! :slight_smile: