And justice for Thrall

Good morning Darrogh,

Disabling addons sometimes doesn’t have an effect because some addons tend to still be active in the background. I suggest to do a full interface reset.

Kind regards

What’s your opinion?

I tried today but it appears that it doesn’t work still. Garosh cannot be defeated due to this bug. Or maybe I’m not worthy? :frowning:

Let’s be honest. This is not the fault of the addons. This quest is just bugged

Disabling addons is not the same as a UI reset, to do one of those you rename the WTF and Interface folders in the _retail_ folder.

Yeah, I tried that too. Unfortunately with the same result :frowning:

I’m experiencing the same problem. I even considered there was something wrong with my character so I started the Nagrand questline all over with a different char but I still can’t do it. Hope this will get fixed soon since it’s the only thing I’m missing to unlock dreanor flying.

Hey all,

This is a known issue which is being worked on, sorry for the trouble caused.

Have a few seconds to spare? Let me know how I’m doing!


Same issue for me too. I have already submitted a ticket around a week ago in-game but no response or anything as of yet.

Tried disabling all add-ons, resetting interface, renaming the 3 folders, dropping and re-starting quest, pretty much everything, still no luck.

Thanks for looking into this, hoping for an update or fix soon.

Gonna add to the row here as well - experiencing the same issue, regardless of re-taking the quest, disabling addons or UI resetting. I do hope a solution is found quickly, as this is a hefty roadblock towards Draenor Pathfinder.

Having the same issue and can’t continue with the storyline. Please fix it asap, it is stopping me to proceed. Thanks a lot!

Same problem here… I’m so sad.

I am having the same problem. I spent a day finishing up the 100 treasure requirement and Nagrandeur achievement, only to have this bugged quest barring me from Draenor flight.


Really nice work here. First there’s Ominous Portents that’s bugged and now this one. I wonder how many more things in WoD are broken due to 8.1

1 Like

Got the same problem. I’ve tried abandoning the quest and restarting but it does not work.

It must take a Christmas miracle to get this fixed soon. We are doomed.

1 Like

Currently still an issue, rather upsetting that this is the one thing stopping a lot of people getting Draenor Pathfinder.

Still not fixed, wrote to a GM 2 days ago never got an answer, probably won’t do anything about it until sometime next year when they are back from holidays…

How freaking great… just amazing Blizzard…

GMs can’t/won’t just complete quests for you even if they are blatantly undoable due to a bug. All you can do is wait and see if/when Blizzard fixes this.

I know of instances in the past where GMs mass granted achivements to players when they were bugged

Are there any news on this? Its also my last step for pathfinder and i would love to finish it, just tried again and still not working :frowning:

Nope no news, this has been bugged since early December when 8.1 came and nothing.
And specially nothing will be done now over the holidays, they are not even answering players tickets anymore

Draenor Pathfinder is dead