Battle for Undercity broken

Just tried it on my DK , still bugged .Varian and Jaina just despawned and we were left outside the undercity

1 Like

It seems to be stuck around the time Thraal shouts “IS THAT ALL DEMON?”

Thrall is walking around in circles, despawning and shouting his lines out of order.

When we are supposed to enter the throne room the walls fall then Thrall and Slyvan run through while everyone is stuck behind an invisible wall.

1 Like

Adding on this from the character I am using for the event,

The ending of the event RP also triggers while the rest of the RP event is still in motion.

I was able to get it to work after around 10 hours. The trick is as follows:

Don’t worry about Lady Sylvanas or Thrall. Sylvanas might just randomly despawn after getting to the elevator. Maybe she respawns at the center in the bottom floor, but she probably wont. Thrall will 95% slowly walk to the Throne Room and run his laps, don’t worry about him.

The most important thing is to kill all the bosses yourself! They are they key for the event triggers! You will see the confirmation at the top that the horde conquered the parts of the city.

Do the following (slightly inaccurate because it’s from my memory):

  1. Talk to Thrall to start the event and wait. Thrall will despawn 1 minute before the event starts.
  2. Go into the yard at the top of Undercity and kill the big boss - it will take some time…
  3. After that, go down the elevator - make sure to not go down before that you’ll bug stuff out! You might need an immunity as the slow fall will most likely be bugged.
  4. At the bottom of the elevator, you will see Thrall besides a monster. If you kill the monster, Thrall will despawn and reappear somewhere in Undercity. Don’t worry about that, just kill the mob.
  5. A huge mob will appear somewhere in the inner ring. Kill it.
  6. By this point, you should have everything besides the Royal Quarters conquered.
  7. Now RUN into the throne room before Thrall even gets closed to the entrance. Make sure you’re all the way in as the ceiling will collapse and the rubble will not despawn and hence will block you!
  8. The endboss will appear and open portals. Kill all the Portal Guards. Once the portals are closed, you can attack the endboss.
  9. Kill the endboss - Thrall will walk his laps while you’re doing it - super helpful!
  10. After you killed the endboss, Thrall will stop his laps and come to the throne. He will talk to the imaginary Sylvanas he sees because he’s so high on whatever they put into that green goo he walked through…
  11. The alliance will come. They will attack you, but Thrall will be a useless piece of an Orc and not defend as he’s inactive again - pull immunities or run!
  12. After 10 seconds, Jaina will stop the fight. A dialog will trigger.
  13. Thrall will walk down and you can actually turn in the quest.
  14. Thank to god or whoever you believe in that you’re finally finished out of this hellhole of a buggy event.

In case you got stuck, you can leave Undercity through the Sewers in the West. Just walk out and wait until the event resets.

I hope this was helpful and Blizzard finally fixes this…

It’s still bugged… What did you hotfix

There is nothing to start the event. Been standing here for 40 minutes and thrall is nowhere to be seen.

Thrall works up until varimatras collapses a tunnel then thrall stops attacking enemy npcs and runs through the rocks in to the throne room and he just runs around the room in a circle doing nothing at all.
Sylvanas and her buff vanished at somepoint once we entered the undercity after the jump down.
Abandoning the quest does not get your uc and ogrimmar unphased from the quest phase and honestly, that’s the worst bit.

Thanks for the additional info everyone!

We’ve identified some additional aspects to this issue and continue to work on a final solution.

More updates in this thread when we have them, or keep an eye for changes to the relevant support article here:

Bugged for me and all my friends too. Happened around 5h ago today so after the morning hotfix.

tl:dr Thrall’s dialogue and the event seemed to reset after the end boss, Thrall disappeared, rubble came back and everyone was stuck untill HSing away.

Then the longer version:

Brewfest music and goblin laughter everywhere (not the best raid music, could brewfest mess this up somehow?).

Thrall kept disappearing/reappearing in different places after we got to the elevators.

Sylvanas was never seen after the event started.

We continued killing the bosses and sometimes Thrall appeared for a bit.

In the end we managed to kill the end boss, but after that when Alliance was supposed to arrive, Thrall started his dialogue from the beginning of the event (“join me behind the walls of Undercity…” or something like that), he disappeared, the rubble in the hallway appeared again and everyone was stuck in the end boss room.

At that point we were waiting for quite some time until we had to give up and HS away.

so what happends to all the brewfest tokens we lose from not being able to do the dailys because they are phased? I was doing them everyday to save up for the outfit for the achievement in dalaran and now i won’t be able to afford it

I’m kinda angry and usually don’t write in the forums, but this situation has to change!

You can’t just have peoples time wasted and say you can not provide a workaround or solution to fix this.
Either deactivate the quest, tell people it is bugged the moment they accept the quest or just straight up let us complete the quest without the event.

We were a group of five and didn’t know about the bug. Do I really need to wowhead every quest I start?! Is there gonna be compesation for all the time wasted?!

Stop making people mad! PLZ!

Thank you!

ps: I forgot to mention the Quest is still bugged! Server EU Razorfen - 29.09.22

Hey all,

As an FYI, our developers announced that they’re working on a workaround to skip the scenario, while they work on a permanent solution. You can find more information here, if needed. :slight_smile:

Every one of these solutions would require a developer to work on this for several minutes / hours, which is usually time that would be better spent on fixing the actual issue. There’s unfortunately no magic button that would allow programmers / developers to implement a solution or workaround.

While it’s obviously not a requirement, the same thing would apply IRL when you have an issue with something, and Google it to find if this issue happened to someone else, or find a possible solution.

That being said, thank you for your patience. :slight_smile:

Im in a weird situation… I picked quest and phased out. Then tried to do it but couldn’t. So I dropped the quest entirely hopping it will fix phase out issue. But no… I’m still phased out in empty orgrimmar. On top of that I can NO LONGER take quest again or talk to Thrall.

I don’t really care about this quest anymore. I just want to use Orgrimmar city to buy honor mount. I can’t buy it anywhere else.

Blue post was saying about 24h solution to skip it. I really hope it will come in next few hours…

Also bugged for me thiis quest thrall diddnt appear at the start after i talked to Voljin only Sylvannas . died 5 times in the courtyard after almost soloeing it with 40k health . threw away the quest relogged and now nothing no portals to undercity nothing ?

Quest is also bugged for me. It just restarts permanently on different phases. For example, we started fight with the end boss then Thrall shout again from the entrance.
The most frustrating probrem for me is that there is Brewfest in Orgrimmar. And with the city phased out I cannot participate in it. Farming prize tickets is crucial if you want to do all the achievments and get a pet. I don’t want to wait for another year.

1 Like

still bugged xD

Holy moly I just finished it! It still is bugged, but somehow stars aligned.

As you can see at the top of the screen, you’ve not finished all the encounters. While you’ve finished the inner sanctum, you’re missing the graveyard at the top (the huge mob waiting after the gates). Once you’ve done that event, the triggers for the royal quarter will start.

So I’ve hearthed, abandoned the quest and am now stuck forever in the wrong phase. I can’t travel to irisfall glades because portals hop me in UC and the zepps dont work in orgrimmar, which is phased as well… How am I supposed to talk to the reset phase NPC when I cannot get to him? You should have put a reset guy where the portal exists in UC as well.

Exit through the sewers.

So I’ve also aborted the quest and ported out. Now I can’t get back to the start because I can’t restart the quest with Thrall. What now?