Cannot log into any realm WOW51900328


#189

The most funny thing is that ipv6 hack works just because their broken ddos system are not analyzing ipv6 traffic))


#190

That’s probably because the DDoS was in IPv4 only. Or do you really think they’re that incompetent?


#191

I’m the same hahaha, so dumbfounded. Been 14 hours since i’ve been unable to log in, getting frustrating now because i’m the only one in my friend group who’s having issues


#192

I think they are. Just think about it, u have ddos protection system, which should, or event MUST protect you from both iv4 or v6 attack, because both are possible.

Attack happens - they implement new rules of packet filtering\denying so linux-packets can’t be accepted, in normal use case you should or even must update these rules (yes broken rules, but anyway) on v4 and v6 networking. That’s simple logic. Because if no - any day ddos can be executed via v6 protocol in the same manner…

So if they haven’t done this, i assume ddos protection just not supports v6


#193

Actually, for Linux users … what made it work for me on Linux / wine again was:
sudo sysctl -w net.ipv4.ip_default_ttl=80

default value should be 64. No idea why this fixes it, but it does (for me) :stuck_out_tongue:


#194

Good news! From US fromus… Instead of using ipv6 you can do this: (you will need root)

echo 128 > /proc/sys/net/ipv4/ip_default_ttl

Default on linux is 64 so they seem to be dropping all packets with ttl 64. Default on windows is 128.


Cant login
[eu] linux users are unable to log in
#195

Aahaha this is GENIUS FILTERING))


#196

sudo sysctl -w net.ipv4.ip_default_ttl=80 Worked! Thank you so much, I’m logged in!
Btw I use arch


Cant login
[eu] linux users are unable to log in
#197

But if that particular attack was IPv4 only, why would they harm their IPv6 capabilities because of it? Maybe if the attacker adjusts the attack, but there’s no reason to cause more damage than necessary. Just look at all this damage right here, it could’ve been far worse with your approach.

The ultimate DDoS protection would be to block all traffic, but that kinda defeats the purpose if you’d like your customers to be able to connect. And yes, obviously this case hasn’t gone perfectly, but I guess it works for most people?


#198

Can you help me with changing TTL windows 10?


#199

Default for Windows 10 is 128. Not sure it’s applicable to your PC.
Are you using a tethered device or a 4g hotspot at all?


#200

I use my phone to share 4g with usb.


#201

You can not do that without rooting the phone. It’s the default TTL Android uses, it’s a system setting.


#202

Then it likely doesn’t matter that TTL you set to your computer as the phone will replace it with its value. You’ll have to change the TTL of your phone.


#203

I was a bit skeptical but it actually worked. Amazing find.


#204

So that points us to that the DDoS is primarily being done via mobile devices, most likely virus infected, and we’re suffering because Android devices are massive and they used it to block out all connections from Linux through the set TTL. That’s a bad filtering option, but the one with the least impact on their services probably.


#205

I’m having the same problem but with a Windows 10 unit. I cannot connect to Classic or BFA.


#206

Some people are reporting the same thing on the French forums (having the issue using Windows 10).

Anybody here know if some ISP or Router performed action could be the cause?


#207

The TTL filtering will affect anyone whose connection either goes via a device that replaces the original TTL with its (significantly lower) default value (for example NAT router could do this), or the connection just plain goes through a large number of hops before reaching Blizzard servers. Measuring the number of steps is what TTL is actually meant to do so packets do not end up circulating infinitely in a network, see “Time to live” in wikipedia since the forum doesn’t allow links.


#208

Awesome, it actually works for me too.
But " sudo sysctl -w net.ipv4.ip_default_ttl=80 " does not persist after reboot.
Is there any way to make this permanent?
Should we?