Cannot see guild chat or guild information


I’m having the same issue as well. Can’t see my guild tab at all but I am still in the guild.


Same here, but i have the problem for like 2 days now and its driving me nuts.

1 Like

Same issue here. I can see the guild name under my own name, but when i open the guild/community tab, i can’t see the guild tab nor the guild chat.


I’m having the same problem, I just made this guild last night for my alts, I have the guild under my name, and bank access, but when I click J I just get the blank screen like OP, so I can’t accept invite requests.

1 Like

Hey guys,

We’ve received a number of reports for these guild issues.
Our devs are aware and are working on this as we speak. There have been some changes that may resolve this for a number of you. However, if you are still seeing issues rest assured that the work continues.

Thanks for your understanding and patience.



one of my Twinks “Basi” joined our guild but can’t see any chat nor chat by myself and i don’t see the guild in “Guild & Communities”.

I quitted and rejoined the guild, but once i exit WoW and start again… the same issue.

What can i do?

Edit: Post was moved to the main thread.

Recently joined a guild, hadn’t logged in directly after invitation but once I had I discovered I couldn’t see or interact in chat or the guild/community feature, at all.

My first thought was that I’d been kicked but got in touch with people from the guild and after many tries with disabling addons, deleting wtf folder etc they, by getting me into a party and doing I don’t know what, eventually managed to get me and my main in and I could communicate with the guild as per normal.

I logged out, played another alt, time elapsed and then I logged back in to find the situation had arisen again. No way of interracting with guildies as we do in-game. Question is: is this a settings problem from the guild’s side when inviting people or is it something from my side? I got in before and eventually everything worked but the situation arose directly I logged out.

This is no fun at all and would appreciate any answers/insights ppl and/or Blizz could give which might solve this issue.

Edit: Post was moved to the main thread.

My guild frame is completely blank (chat, communities, members etc) on one character only.

I can see achievements and login/outs from guildies in the chat panel, but not the big guild panel itself.

I saw many posts about this issue on Jan 20, it’s hard to believe no fix has been found yet?

If anyone has any solutions (ideally that dont involve deleting all my cache and wtf folders and losing my customised interface) I would be very grateful.



Hey there Arashiko,

Would it be possible to provide to us a screenshot of this issue, so that we can better understand the particular problem that you are encountering?

Also not certain if you have tried this so far, I would suggest that you reset the user interface as this article suggests.

1 Like

How can i upload a screen if i don’t have the trust level? have the same issue as him.

I can access old guild tab through /groster
Below my name i see the guild
Here in the forums i also have the guild tag.

It works on all my characters but not on my main, who got a guild change today, it was working when i got invited but a few hours later my guild tab is empty, but works using /groster, still no access to gchat

Same problem here, most of my guildmates have it too, this is quite annoying since I’ve just created my guild today after a breakup of my old one.


I have the same issue. I joined a guild today, a few hours ago, and I just noticed the same problem described above. I can’t see the guild roster, neither the guild chat (only achievements earned) when I press the “J” button.

When I click the “Roster” tab, I get this message:

Message: Usage: local privilegeInfo = C_Club.GetClubPrivileges(clubId)
Time: Fri Apr 9 23:03:17 2021
Count: 1
Stack: Usage: local privilegeInfo = C_Club.GetClubPrivileges(clubId)
[string “=[C]”]: ?
[string “=[C]”]: in function GetClubPrivileges' [string "@Interface\AddOns\Blizzard_Communities\CommunitiesFrame.lua"]:552: in function HasCommunityFinderPermissions’
[string “@Interface\AddOns\Blizzard_Communities\CommunitiesFrame.lua”]:606: in function `SetDisplayMode’
[string “:OnClick"]:1: in function <[string ":OnClick”]:1>
[string “=[C]”]: ?

Came here to say that I’m experiencing the same issue on my alt but not on my main.

I did a gquit and rejoined the guild its started to work again

and it’ll probably be broken again, a friend of mine told me that not doing anything fixed it in a few days, but it should still be fixed.

1 Like

same problem here. what i can do ?

1 Like

Is there any update on this? Everything is fine on my other toons, the issue exists only on this paladin. I can’t see the guild chat either, I can see only when someone earns an achievement or comes online or goes offline.

I deleted all addon realted folders, Iterface, WTF, no addons, yet nothing chaged.

When I was invited to the guild everything was fine for a few hours, then the problem occoured. I also noticed some strange flickering in camera movement, but it also only happens on this character. FPS is at 60 (vsync on), yet it doesn’t look as smooth as before.

I had a gpu driver update this morning, first I thought it’s the issue, then I installed the earlier version, nothing changed. It looks like I don’t have the fps, but I still have it.

Put the link between two ` marks for preformatted text.

The result would be something like this: