Envoy Charter 10.0.7 bugged

Same as https://us.forums.blizzard.com/en/wow/t/envoy-charter-1007-daily-not-working/1550948 and https://us.forums.blizzard.com/en/wow/t/envoy-charter-1007-daily-not-working/1550918 but you can’t post cross-region…

Trying to take Maruuk Centaur bonus (for the 2nd time) and it didn’t work. I was able to pick up the Valdrakken bonus, however - perhaps you need to do each faction once before you can do repeats? If so, that isn’t very clear.

EDIT: On the following day, having done each faction once, I still can’t get the Centuar bonus, but I can get Tuskarr (second time I’ve taken Tuskarr).


Yep, can confirm I’m also seeing this EXACT same issue.

Trying to select Maruuk for the second time but after giving me the prompt and me pressing “Okay”, it doesn’t do anything, and the blue quest marker remains.

Worked fine when I selected Valdrakken accord though (first time unlocking)

The Group with someone not-broken and have them party-sync workaround worked for me.

I too am being impacted by this issue. I am able to select nay of the envoys except the Centaur which silently fails to work (IE no error messages are shown but the buff is not applied to my character and the quest to select an envoy remains available).

Getting this issue again…seems that once you have this issue you need to use a workaround every time you want to take the Centaur bonus…

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.