Game doesn't work after 8.1 patch


#332

Sup Guys

You can add me to the list of unhappy Wowers after the 8.1 update. game was working fine before the update and well guess you can figure out what happened. my Laptop is up-to-date with all drivers and the problem is not my Laptop it is the update. Blizzard needs to just admit the update is at fault. My Husband is running his game on NVIDIA and no problems well mine is AMD and not working.

Please don’t tell me it is my drivers or ask i run a test. my Laptop work 100%

now what to do with my FREE Time :rage:


#333

Same problem. If You want play for 5 minutes, just wait ~10 minutes when the black screen appear and do nothing.

AMD Radeon HD 8670M


#334

Same Issue hear, although i’m running on a Nvidia GTX 1050Ti. The game does not launch or when it does it takes about 5-10 minutes. When it does show up in the task manager it says it’s loading at 10 mb/s in the network column and my internet slows down dramatically. I’ve done all the above. And i had noticed after reinstalling WoW and running it as a “Stream” (background downloading) it worked flawlessly besides the loading screens for obvious reasons. After it had been fully downloaded again i started getting the same issue, WoW not launching although the battlenet launcher says game is running.
Also the Main WoW folder has been rearranged maybe that has something to do with it. Dictionary wise in windows or anti viruses.


#335

The worst imo is that we do not even get a reply from Blizzard.
There are some new posts instantly getting feedback (maybe automated?) and this post with >300 replies doesn’t.

Maybe we need to create some new Threads?


#336

How I solved the blackscreen problem (NVIDIA)

Was playing the game with DX12 without any problems since patch launched.

Today I got a blackscreen when i log in to my character. For me it worked with changing to DX11 and only using 1 monitor. When Im using 2 monitors I get blackscreen. Could be that there is a problem with monitors using displayport or just by having two monitors.

Now its working fine again with just one monitor connected with a HDMI cable. I hope this help any fellow NVIDIA user who also have this problem.


#337

Almost one week and blizzard still didn’t solve the issue!!! I request compensation 1 week of game time


#338

Blizzard should not blame users.
The problem started with the patch.
And i dont see any repair patch.


#339

Funny thing, before patch 8.1 worked fine but after that boom


#340

Update to my case, I was so annoyed that I reinstalled windows 10 from scratch. Streaming wow worked fine, as soon as it was downloaded completely it won’t launch again. FFS this is driving me crazy…


#341

We’ve lost 5 days of game time and hours of our free time (I’ve installed/uninstalled almost everything from the game itself to Drivers and Win), our nerves are shot and nothing yet. Please Blizz do something…


#342

I’m usually not the type asking for this, but as the issue is persisting without response from Blizzard I will now also create a ticket asking for gametime back…


#343

I’m glad it’s not just me - but with a 2015 iMac which sports the graphics card top of the ‘supported’ list… it’s hard to see how they could have missed this one out in their testing. Which means either they didn’t test, or they did but thought ‘lets get this out before the holidays so everyone is completely screwed’… which would be sad.

FWIW, I’m Disconnecting (seeing an endless entrance bar) right before going into BGs - our team fought with 9 men 3 times the other night before I gave up. I’ve removed WTF and Cache and all my addons which does work, but is seriously tedious - doing rBG without BGE is pretty much impossible. Making sure they’re all running the right version number (edit by hand) works partially, but not completely. We now crash out on leaving the BG, which is better than nothing, but still really irritating. And was kicked three times on trying to log in yesterday. Ticket to Blizz got back one of the worst ‘not our problem mate’ answers I’ve ever seen…


#344

At my wits end now. Thought it was only me, but after testing on multiple PCs, it seems to be the AMD card inside my laptop doing this. Blizzard’s handling of this situation is appalling. Getting very disappointed in the company as a whole now. Diablo, screwed up. HotS being reduced. WoW is having terrible customer service… I’m left with Hearthstone, and I’m wondering how long before they mess that up again.

Get your act together Blizz. If the ratio of people saying its the GPU’s fault, to those not is 20 : 1… You really gotta think there’s a reason for that.


#345

Update! I figured out that if I’m not connected to the internet the game launches fine. just need to reconnect the internet after it launches and then it’s good to go.
I figured this out by accident because my router DCd while i was launching wow. so it might be a firewall thing.


#346

Ok guys, someone should make a “rant-video” thingie about this on Youtube. Need to get more attention for this somehow :S


#347

Yeah I totally agree. Blizzard seem to even be ignoring the thread despite the overwhelming number of posts. How much does it take to make them fix this problem…

I’m holding out hope that the silence is because they’re working on a hotfix that will roll out with maintenance tomorrow.


#348

AMD Radeon user here!

I had to switch to Intel HD Graphics 4000 and now the FPS doesn’t go above 15. Can hardly play properly. Blizzard, please do something!!!


#349

AMD Radeon HD 6700m user here.
I have same black/white screen problem. I spent 10+ hours for now trying to resolve problem and still no results. Is it possible that there is no fix for this?


#350

Not as yet @Twinzeey and I’m seriously starting to consider taking my money elsewhere, had this problem since Tides dropped. I hear FFXIV is a great game…


#351

Lizzard what us all to sort this ourselves to save them the bother they all need a Christmas bonus and working this out cost them