Game doesn't work after 8.1 patch


#352

As seen, many people including myself have the same problem.
So, we have the same problem all and we have to solve it or, Blizzard is trying to reduse the population of the game with a “mistake” made at the last patch.
I am still waiting for a repair patch that will give me the access to choose the previous aspect of the game even if i have bad graphics.


#353

This works for me for 2 days had to re do but started up again. TRY IT!

  1. Open the Battle.net app and go to Settings
  2. Click Game Settings
  3. Check Additional command line arguments for World of Warcraft
  4. Type in -d3d11
  5. Click Okay and launch the client

#354

Windows 10?


#355

As already posted this is NOT the fix for the issue with dedicated graphics.
In this post, two issues are being talked about. One can be solved by -D3D11, the other needs a fix by BLIZZARD!


#356

Agreed but if it gets people playing which is what it is about.
And yes windows 10


#357

This is retarded at this point , 6 days have passed already and still no response or fix.


#358

So my boiz, do you have any other games on your computer which has the same or higher requirements than WoW? (I only have WoW and ol’ D2, so, that doesn’t help, hehe.) If yes, do they still work fine? For some reason I suspect: yes.


#359

Same here, starting from patch 8.1 i am not able to log in into the game. Was told by tech supp that i have old graphic card and that i need to update my laptop. Once i put wow launcher into compatibility with windows 8 i was able to play the game on high/ultra graphic. But now again still not able to launch wow. Worked perfectly fine before the patch. Any other game, like dota2, starcraft 2 etc is running perfectly fine or high resolution. Very frustrated from all of this, didn’t expect this kind of treatment from company like blizzard (or should i say activision now). Instead of fixing the problem and help people that are paying them money, they will release a freaking mount for 25 $ instead :slight_smile: nice move


#360

Today’s patch didnt solve a thing. Still im forced to play in dx11. Some ppl not even playin. Nice work blizzard not even surprised.


(Sanoola) #361

I removed my AMD driver and software and can now play this game on my intel HD4000, how come my AMD HD7650M is not supported ? but a crappy intel onboard gfx can play the game ?
Using win 8.1


#362

It seems the game is very much broken today, too. While I have been levelling a character in Vol’dun I’ve experienced an inability to pick up quests, quest logs that won’t update and an inability to attack Emperor Korthek during the quest related to him.


#363

I think i fixed it. I have AMD Radeon HD 8670M, Win 8.1 x64. I downloaded www.amd. com/en/support/kb/release-notes/rn-rad-win-18-9-3 (delete space in link) for Win 7 x64. For me it’s wornikng. I can even open a system menu in game. I hope it will help You.


#364

Todays patch didn’t helped at all. Still the same issue.


#365

So up until last nights patch I was running things fine and leveling absolutely fine. Now on Silvermoon-Eu trying to do the Draenor scenario and i cant complete it or hearthstone out of it because the world lag basically stops the game from functioning. Only way to escape the game is Alt+F4. Over on Magtheridon I have a good 2 seconds wait between each cast and opening chests but can at least log out. Todays patch just broke the game for me.

Edit 14:17: so i can actually play now and world lag has vanished.


#366

I think the problem with this post is that the name is quite unspecific and that because of this people are posting on different issues.

Thus, the main issue of the game not starting properly (freeze/whitescreen) especially on mobile gpus is not popping up on Blizzards radar.


#367

They are just too busy working on phone-diablo and Blizz-shop-monunts. -.-

(Because of curiosity I took a look the cost of the better vid-chards for laptops and…not only my heart broke out shrieking from by ribcage but my entire circulatory- and lymphatic system gone with it aswell.)

Stay srtrong buddies :frowning:


#368

Hello so if i have graphic card: Intel® HD Graphics 4000, now after release update i cant play wow?? :confused:

thx


#369

Intel HD Graphics 4000 was below minimum spec for Legion, let alone BfA.

One of the problems talked about in this long thread is that many laptops have both an integrated Intel graphics processor and a separate, more powerful, graphics card (generally AMD make) and this combination is currently not working properly since 8.1 without some workarounds. The game should use the more advanced card, but fails to do so automatically.


#370

Maybe it’s AMD problem, 'cause I cannot turn off an integrated one, without turning off the main g.card, even in BIOS. And most of these problem cards are long off date, and more than that - one cannot even update it’s drivers for the last half of the year.
Yet another reason not to deal with AMD.


#371

But it’s not just AMD users. There are Nvidia users experiencing this issue as well.