Game doesn't work after 8.1 patch


#372

Ever noticed that only amd-users have problem with “switchable graphics”, nvidia-ones are troubled with dx12. Anyway it’s very strange… And it’s bad from both ends.
If drivers are the problem, then we have to wait for update, which may never happen.
Or if it’s on the Blizz - they will fix this… eventually.


#373

Cancelled my sub, i see there is no hope.


#374

Yeah, you aren’t the only one. They’re screwing over AMD and Nvidia users. I give up on Blizz. It’s been this way since the 12th December, come on


#375

Here is the solution that helped some people.
They say that the problem is the incompatibility between AMD and Intel graphic drivers. The trick is to find compatible drivers, that will not break each other. I’m going to try the 16.2 drivers and check if it works.


#376

Wish Nvidia users had a fix.


#377

Its just important to stoicly keep posting here. Eventually we will get a bluepost at least finally…


#378

I agree.
Even if some of you go and create a new thread about his/her specific problem, please keep on checking back here, because it’s important to keep this thread alive. We got 5k view guys, and it is still growing. If you take a look at the statistics our thread leads the tech. support category.

Chin up me hearties :wink:


#379

Simple solution for AMD/Intel graphics users : If you have a notebook with AMD graphic card and intel processor with intel HD graphics, switch graphics from amd to intel … this should fix the whitescreen crashing. (temporarily)


#380

The only slight problem with that “fix”, using the integrated graphics chip in the CPU compared to the dedicated graphics card. Is it’s like saying, “My Ferrari won’t start, but I’ve solved the problem, as I had a tricycle in the garage that works.”


#381

"The only slight problem with that “fix”, using the integrated graphics chip in the CPU compared to the dedicated graphics card. Is it’s like saying, “My Ferrari won’t start, but I’ve solved the problem, as I had a tricycle in the garage that works.”

Make my day.

I´ve the same problem. Wow don´t start since patch 8.1. My thread is in the german forum. Laptop with switchable graphics. Intel prozessor with AMD Radeon HD 7970M. Sorry 4 my bad english.


#382

Just want to remember that if you leave the game on whitescreen in the background, after ~10mins it will load.
Dont enter the settings menu, which causes a crash again!

Basically your Ferrari starts 10min after you switched on the engine. Dont turn on the radio tho, it will crash afterwards :wink:


#383

For me it was that the game wouldn’t launch, press the button and the game process would just be killed off. I fixed this by putting the wow.exe into compatibility mode with windows 8.1, after that I took compatibility off and it still launches.

I spent 3 days arsing about with this, I originally got some adware on my machine and was forced to reinstall win 10. After that there was nothing I could do to get the game to run and I tried a lot of things so that fix may not work for everyone.


(Geozyllane) #384

Dear Blizzard,

There was 2 patch for one day. The wow.exe remained tend to consume more and more memory, and rather slow. While its crashing tend to be random. I think so, that your QA-team is not the world’s best one.


#385
  • Sorry, Lilblindcrow here, just forgot to switch the character.

Well guys, I tried to be as polite as possible, tried to use the language a way to avoid bann or something, tried not to be (too) rude but that’s it.

We bought a bunch of expensions, be payed for gametime for years and this is what we get.

You know, for me the worst is not really the situation that I can’t play (however it is kinda bad to be “clean” since a week) but their behaviour.

I’m officially ourtaged!


(Geozyllane) #386

I tried to locate the crashing points. So, the modules call for BAZ (e.g. island expeditions, dungeons, or even the teleport to Boralus is very slow and seem to be changed by a very lazy way. As I mentioned earlier, there are probably new libs without accurate testings. On the other hand there are probably some inadquate, but cheap developer incorporated from a nursery.
Please testing the application, fix the memory leaks, and kick off the the developer, who couldn’t use, or handling a correct reference for any object used to feed the memory.


#387

i still can’t launch game on using my amd gpu come on blizzard fix this


#388

Maybe if we all posts ‘Blizzard please fix this!!!’ each and every day it will be enough for them to notice :slight_smile:


#389

hi sorry for my english yes 10 min is good, after clic menu système in game = crash deconnexion = ok. after clic système menu indentifiant, change your configuration


#390

Problem is still there, yet they dont care. Im wondering do they even read these forums lol…


#391

Hey everyone, I was playing WoW before the patch perfectly. When patch came out, that game doesnt even start, screenfreez and for a week there are no changes. Hey Blizz, your patch is a broken patch. You may continue to close your eyes on this topic, but know this, people are upset, people are struggling to enter to that game, people are confusing. Should people pay for this every month? I guess no, never ever! Our payment is your bread on the table. Your patch has broken everyone’s good expectations of this update. Please keep in mind that people who made post on this topic are really upset, all of them. I personally love WoW from my childhood, but i’m not gonna pay you not a single cent if you dont fix it. Peace