Issue with AH and buying Items

I cannot buy Feast of Gluttonous Hedonism from the AH. Every time I try to do so I get Internal auction error. Doesn’t matter if I select 1 item or 5 I constantly get this error. I have made sure all of my addons are up to date and ran a scan & repair on the client but nothing works? Anyone else getting this issue?

Have you tried after turning all your addons off?

I have just tried it with all addons disabled at it is saying the exact same thing. Internal auction error then shows me a loading screen and if i wait it doesnt do anything after that.

Did you recently fall foul of the AH duping? Can you buy them on other characters?

I’ve tried buying on this and my Shaman but neither works. I haven’t heard of any AH duping so if that was the case it was entirely by accident

Did you ever get gold for an AH item that didn’t sell? That’s duping,

The only thing left I can suggest is a full UI reset, which is deleting the cache folder, and Move the WTF and Interface folders. You can tell it works as you get the intro movie.

If that doesn’t work try opening a ticket.

I have exactry the same issue. I tried everything but can still not buy it. Otherwise i can buy other items without a prob. Only [Feast of Gluttonous Hedonism] dosent work.

Same issue here! Even tried with the mobile auction house (i.e. definitely without addons) for the same result : Internal auction error

1 Like

We’re aware of a bug that is causing some items to get stuck in invalid listings.

This is a priority for us to fix, however, we expect the fix to take 2-3 more days.

We’ll let you know as soon as the fix is deployed.


Can we get a breaking news untill the AH is back online? it is been down for quite some time now

1 Like

ok so auction hous is now lockd on dreanor
plus i have a token for sale so dont think i am geting that gold any time soon :smiley:

If the issue is caused by the mobile Auction House, then just remove it. I don’t know anyone that places auctions from their phones personally

1 Like

You cant post on Mobile AH, only buy

Do you need some help?

Have you considered testing stuff before release? I hear it’s a thing.

Have you called Microsoft support? Perhaps they can provide some QA ?

Come on man, give ’ em a break.

They’re too busy ruining basic flying for 10.0 to have time for minor bugs like this.

So its 6 days later and lots of the auction house is still broken, any update?

1 Like

have you tried using ah with all addons disabled, just to be certain?