Karazhan chess event loot bug

Karazhan chess event loot is broken like hell now. :angry:
If you win the event (defeat boss) get this “message”


Like i joined the raid after boss kill. Can’t use the chest (no cogwheel) and can’t restart the event also. Still can progress to the last boss but that’s all. Tried with multiple chars with the same result. Tried without any addon with the same result.
Just farming transmogs but without loot this is a LITTLE bit frustrating.
Anyone know a solution or workaround?

PS: My first post here. What is this “no link allowed” thing???


Support don’t handle bugs. Bugs must be reported in-game via the bug reporting tool.

You will not get a personal reply, but all bug reports are read.

You can no longer embed links in the forums until you’ve earned a specific level of trust. Instead they must be wrapped in `` which makes them “Preformatted text” rather than a hyperlink.

This is to stop the few nefarious trolls who were linking to viruses and trojans, I guess.

I would try doing a run without any addons enabled and see if it works. If it does then one of your addons is the culprit.
I see you don’t run it, but for instance ElvUI is heavily bugged on chess event.

Thanks the advice i already did that before came here. This place was my second thought because maybe somebody already met this problem. I found an old topic about Karazhan chess event but their problem was the disappearing/reseting chess piece. That didn’t happened with me fortunately i can leave and enter with no problems. My problem is at the winning move. The game think i’m not there when i win the match. A little bit confusing when you are doing solo. :smiley: (If i have time will try to do in party. Maybe the bug is only occur when you are alone there. I will update this post after tested my idea)
And thanks the info about posting “rules” i didn’t knew this. Acceptable rule but it is make the help request a little bit difficult. :grimacing:

Thanks Debra i already tried that.

…Tried with multiple chars with the same result. Tried without any addon with the same result…

That was my third try, just didn’t make a screenshot about it.
But thx anyway. :smiley:

It is still bugged.

1 Like

Still unable to loot TBC Karazhan Chess event after defeating it.

Bumping that thread - it IS still bugged as hell…

Also, it seems someone (devs?) somehow broke event itself, there is good chance to see at same time both “cheats” from Medivh (Fire under some of your pieces and buff on some enemy’s pieces) in less then first ~ten moves or so.

I barely hope not to see (semi)official answers like:

  • Devs not bothering with “old content” ;
  • “Working as intended” ;
  • “We’v tested and didn’t find any probs on our side” ;
  • “That’s not a BUG, that’s a FEATURE” © ;
  • Make a bug-report to devs and make ticket to get your loots ;

Problem still persisting regardless of the fact - how “old” content it belongs to.
And I also hope, both supports and devs have clear understad of how much frustrating and demotivating are situations like this, aswell as how… stupid and ineffective is trying to “fix” it by “make a ticket -> get loots via in-game mail on that char”…

Additional clarification regarding the conditions of bug - seems it happens in ANY case, not matters if you playing with addons or without any of them, also not matters how many bosses defeated before (as very minimal it’s Moroes+Opera to pass further).

I can confirm it’s still bugged. I run it each week for transmog.

Can solo the event no problem, get the same message “you have entered an instance already in progress etc…”. Chest is there by the staircase but is unlootable.

I’ve tried with no addons. I’ve tried different ways of ‘exiting’ each piece but no luck. Unfortunately I doubt the Devs are worried about minor bugs in decade old raids but it means I can’t get the transmog set as there are no substitutes for the Forestlord Strider boots.

1 Like

Yeah. It really sucks. Can’t loot it either, and i miss the boots only for the set, and the achievement…

It is still bugged, just enlisting all possible loots which ppls missing (with a bit of comments)

Totally loot table for chest has 12 entries, from which - due to accent on transmogs - 2 things can be surely thrown out. 1 amulet and 1 ring.

From the rest 10, breakdown by types:

  • 1 cloth ;
  • 3 leather ;
  • 2 mail ;
  • 2 plate ;
  • 1 sword (originally tanking) and 1 shield (originally healing)

Notable ones:
Headdress of the High Potentate - very nice one;
Bladed Shoulderpads of the Merciless - reminds rogue T2 shoulders, not bad;
King’s Defender - nice-looking one;
Legplates of the Innocent - part of “Karazhan healadin set” which overall looks impressive;
Triptych Shield of the Ancients - also part of “Karazhan healadin set” with interesting look.

Can confirm this is still bugged. Tried last week and this week.

Confirmed, been there yesterday, killed alliance king, chest was there but couldn’t interact with it.

Can confirm, still broken.

Can confirm, it is still bugged.

Did it this week again and still bugged, i win with ease, but everything i can do is talk to Medivh to reset encounter, i was even killing all other pawns to be sure i wiped ally from the board but with no effect, when i did reset fight, opposing faction didn’t move, they could only attack if i was in their range. Chest was still bugged so GG, because 1 or 2 months ago it worked.

1 Like

I think you’v miss-typed and was intending to write “1 or 2 years”.
Cuz, it is still bugged, and this “still” is definitely more then 1-2 or even 3-4 monthes (just lots of ppls noticed that bug long ago but simply didn’t reported on forums due to lazyness and/or “hope of soonish-fixation-of-it”) …

Does community still can hope to see official explanation on this case?..

1 Like

I’m sure i did loot this on my pally or warrior 1-2months ago, i could loot chest so i was surprised, but every other time i went there for my Despair mog doing full raid ofc i couldn’t loot it. Maybe there is 1 tactic which works as intended, and we all are following guides which let you win, but game is not considering this win.

I just did a try, i can confirm that it’s still bugged :frowning:

Still bugged unfortunately.

And yes, still bugged.