Necrolord Covenant quests bugged

Just started the Necrolords covenant quest and after i pledged aligeance at the statue the phasing bugged, in the quest “Anima is Strenght” i have to talk to Arkadia Moa, but i cant talk to her at all, same with “Bringing it all together”, I’ve tried to abondon them, but it’s like the area is phase stucked


Same here.

Hi Gugglar,

If you’ve recently changed covenants, (or even if you haven’t!) there can sometimes be issues around the chapter 1 quests. It may be worth opening a ticket to have this checked into further.

I’m also stuck! :frowning:

Yes i changed my character from Horde to Alliance, and after transfer i changed covenants from venthyr to necrolords.
Man i’ve been clicking around on that customer support page so much and i never figure stuff out. When i’m trying to make a ticket, i always end up here on the forum.
I’m losing alot of covenant lvls on this…

And i only got one covenant ability, I have fleshcraft but not Primordial Wave

same problem i cant talk to the npc
have any of you guys solve ur problem

Hello Guys.

Same issue here. I opened a ticket yesterday. I logged in with my DK now , but the problem is still here. Anyone know how long i need to be waiting until someone will solve it? I need to pass my mythic raids in progress…

I have similar problems here:

Covenant introduction not progressing, cannot gain renown, cannot progress, cannot get soulbinds. It boils down to that my character is locked out of this expansion - Support / Technical Support - World of Warcraft Forums (

made a ticket and the GM told me to report the bug and thats it.
I’ve had quests reset for me in the past, so I dont see why this can be done now.

I am basically locked out of content wich I payed (and am paying) for, which is pretty unnacceptable.

Either bumps us up a bit in the campaign or have us complete the quest.

Hi there,

Please see the post here for more info on this issue:


I’m stuck too, and i don’t know what to do …

Any chance to get the hotfix within today ?

Would not count on it.
Power of the primus is not my issue, I CANT deliver Anima is strenght and bringing it all together. please fix this, it’s been 3 days. I’m paying money for this
(I cant accept Power of the Primus, it’s just a “!” without anyone beeing there

At least it’s not me then. Absolutely gutted. Couldn’t of got grinded on me renown and soulbinds today. Typical blizzard tbh paying for a poor service

YES! Now it works for me, I didnt do anything so i have no “fix”, probably something blizz fixed for me

Omg mine too I saw your post and checked. Finally.

did u get ur problem fixed