On beta but can't access forums

Hello,

I got into the beta last week and have wanted to post some feedback on the forums. However, I currently cannot create posts or reply to existing ones. In game it only lets you submit bug reports at the moment and most of the comments I have are not related to bugs. Is there a way this could be resolved?

Thank you

1 Like

Try logging out of the forums, clearing cookies and then logging back in.

Also checking you’re on the EU beta forum. They’ve split it for once - https://eu.forums.blizzard.com/en/wow/c/in-development/dragonflight-beta-test/302

Thank you for the suggestions Afenton and Ananda. It is definitely the EU one I’m trying to access. I’ve also tried logging out, clearing cookies, resetting my password, switching characters, and none of it seems to be working sadly.

I too am having this issue, can’t post anything in the beta forums (I’m on EU forums for the beta too).

Any solutions to this issue yet?

Which beta are you in? Dragonflight or Wrath?

Dragonflight

This issue is still happening. Are there any other solutions?

Hey Kaliroth,

The beta forums should be accessible to anyone who received a beta invitation to Dragonflight. If you are still unable to participate in the section linked by Ananda, please do follow the solutions provided on this guide. :slight_smile:

Hi Yryadorne

I have tried everything on that list and it still is not working.

I don’t know if this might have something to do with it, but I won the beta key through a screenshot competition on Twitter. This one for reference: https://twitter.com/Warcraft/status/1570819813953372163

I was given a key to copy and paste in. Could this have something to do with it?

Thank you.

Thanks Kaliroth,

That may indeed be the issue here. I’ll check to see what can be done about it. Thanks for your patience! :slight_smile:

Thank you, I appreciate it

You should be good to go, Kaliroth!

If anyone else sees this thread and has the same issue, you should now be able to solve this by logging out and back in. :wink:

2 Likes

Yay thank you so much!! Greatly appreciated and hopefully it helps anyone else with the issue. :smiley:

1 Like

This fixed it for me i had the same issue but i didn’t get my beta key through any contest

I have this issue and relogging isn’t working for me.

Its not just a case of relogging.

  1. Log out.
  2. Clear cookies.
  3. Log back in.

If that doesn’t work, reset your password to force a server resync.

Done all that, doesn’t work.

I have same problem can’t post reply or create new topic on “Dragonflight Beta Test” T.T

Phii, you need active gametime or an active subscription to post anywhere other than technical or customer support. So make sure you have active gametime or a subscription.