Small lag on quest turn ins and WQ completed

Same issue here and I don’t have any add-ons. I’ll try the ‘tip’ about changing war mode status (which works when my additional action bars go missing or my colour blind filter goes off - just set them to off and then on again).

Same problem for me, disabled all addons and still happening

Same here, tried all kind of suggestions.

This is what happens when you get new animated or new screen layer/label in wow, doesnt matter if its neck lvl up, char lvl up, opening azerite, turning quest, talking with npcs etc.
100% Hard Issues or atleat HDD issues.
i have a screenshot and i can not upload it in the forum or putting a link for proofs.

1 Like

Same issue here, disabeled addons and did a scan and repair and same problem

Same here, small freezes every now and then, at random intervals.

Hey all,

I know that this is frustrating but our Developers are currently investigating this for us based on all the reports we’ve received about this. If it’s possible, can any of you that have WoW installed on a “regular” Hard Disk, and have access to a Solid State Drive, try moving WoW to the Solid State Drive as that has seemed to help a number of players experiencing this.

Another potential workaround is to fully reinstall the game. I know that this may be inconvenient for those on slower internet connections, so please only try this if you don’t mind the wait for the game to redownload. If you would like to try, you can you follow the steps in this Guide (there is an Advanced Troubleshooting section here that I would also advise you to work through) to uninstall the game, and once you have done that, reboot your PC, and then install the game again. You can do this either from the Blizzard app, or from the Game Client download page.

Once again, I’m sorry for the inconvenience this is causing you all, but if the above steps don’t help, our Developers are investigating as well and hope to have a fix soon.

1 Like

or how about you fix your game…

12 Likes

Typical “Sir, please disable Your addons, delete WTF, Catche folders, or reinstall whole game, and if not work, send files of Your spec and then we tell You to reinstall game” I been thought this like 3 times, game works after “guide” but still work as sh!t, constant fps drops, freezes etc.

Guys, You said this to us since WoW starts. I explaint this: Its not addons, its not our systems, its not game client from our side. Its just 8.2.5 have an ERROR. Please fix it.

1 Like

I once again question why this went out of the PTR, let’s not forget the sudden disappearance of the Orgrimmar Zeppelins after the war has ended!

Especially since many pointed out that reinstalling doesn’t work, I was dumb enough to try it anyway this morning with a clean install (I even uninstalled the launcher and every files) and still the same stuttering, it clearly comes from them and apparently a lot of people point at their messy group sync feature

Question, if I were to go ahead and -buy- myself an SSD to be able to play before the reset to eliminate the wait time for a fix, would I have to completely UNINSTALL the game or will I be save to simply MOVE it?

Do we have any idea of an eta for a fix?

Moving should work

I have wow installed on my internal hard drive, but not on the SSD. However, I’d rather wait for a fix instead of moving wow on the SSD which I need to keep as clean and tidy as possible…

If it could be avoided it would be better for me.

1 Like

WoW has been working fine on my HDD for years but now suddenly it’s a problem?

GJ Blizz

Experiencing this too, normal HDD. Done all the usual except reinstall. Don’t have the space to have it on the SSD. Completing quests, opening chests, killing rares.

I posted last night about a temporary fix that worked for me involving using the mklink /J command in cmd to link folders from my wow installation to folders on my desktop. I did this with “WTF”, “Cache”, “GPUCache” and “Logs”.

I play on an external SSD because my computer’s too small to hold wow atm so I figured since nothing else was working, this was my suspect nr 1.

I took a copy of my installation and tried to narrow down which folder it was that was creating the most issues and I think I narrowed it down to it being the “Logs” folder in the game files that resolved most of the freezes once I had it linked to a folder on my Desktop.

I went to a world quest and logged out of the game. Opened the Logs folder in the backup that had no mklinks and cleared all the files of all text before I relaunched the game to see what would happen to the files once I tried completing a quest. It seems it’s 1 file being written on when I picked up and completed a world quest. The Hotfix file. So I logged out and back in and decided to see what would happen to it from the moment i picked up a world quest to the completion.

After completing the world quest, I got the freeze like we all have been getting everywhere so then I checked the file in the logs folder

Hotfix:

|9/27 04:47:36.213 |DBReply Table BroadcastText RecID 155768 valid|
|—|---|
|9/27 04:48:17.826 |DBReply Table TactKey RecID 279 invalid|
|9/27 04:48:17.879 |DBReply Table TactKey RecID 282 invalid|
|9/27 04:48:17.928 |DBReply Table TactKey RecID 272 invalid|
|9/27 04:48:18.003 |DBReply Table TactKey RecID 245 invalid|
|9/27 04:48:18.061 |DBReply Table TactKey RecID 113 invalid|
|9/27 04:48:18.090 |DBReply Table TactKey RecID 252 invalid|
|9/27 04:48:18.149 |DBReply Table TactKey RecID 251 invalid|
|9/27 04:48:18.190 |DBReply Table TactKey RecID 112 invalid|
|9/27 04:48:18.238 |DBReply Table TactKey RecID 109 invalid|
|9/27 04:48:18.268 |DBReply Table TactKey RecID 259 invalid|
|9/27 04:48:18.305 |DBReply Table TactKey RecID 255 invalid|
|9/27 04:48:18.334 |DBReply Table TactKey RecID 246 invalid|
|9/27 04:48:18.371 |DBReply Table TactKey RecID 234 invalid|
|9/27 04:48:18.401 |DBReply Table TactKey RecID 111 invalid|
|9/27 04:48:18.460 |DBReply Table TactKey RecID 110 invalid|
|9/27 04:48:18.490 |DBReply Table TactKey RecID 249 invalid|
|9/27 04:48:18.527 |DBReply Table TactKey RecID 283 invalid|
|9/27 04:48:18.557 |DBReply Table TactKey RecID 267 invalid|
|9/27 04:48:18.593 |DBReply Table TactKey RecID 108 invalid|
|9/27 04:48:18.635 |DBReply Table TactKey RecID 107 invalid|
|9/27 04:48:18.693 |DBReply Table TactKey RecID 237 invalid|
|9/27 04:48:18.723 |DBReply Table TactKey RecID 281 invalid|
|9/27 04:48:18.760 |DBReply Table TactKey RecID 273 invalid|
|9/27 04:48:18.789 |DBReply Table TactKey RecID 277 invalid|
|9/27 04:48:18.891 |DBReply Table TactKey RecID 229 invalid|
|9/27 04:48:18.959 |DBReply Table TactKey RecID 266 invalid|
|9/27 04:48:18.989 |DBReply Table TactKey RecID 73 invalid|
|9/27 04:48:19.026 |DBReply Table TactKey RecID 260 invalid|
|9/27 04:48:19.055 |DBReply Table TactKey RecID 95 invalid|
|9/27 04:48:19.114 |DBReply Table TactKey RecID 265 invalid|
|9/27 04:48:19.144 |DBReply Table TactKey RecID 230 invalid|
|9/27 04:48:19.192 |DBReply Table TactKey RecID 261 invalid|
|9/27 04:48:19.233 |DBReply Table TactKey RecID 275 invalid|
|9/27 04:48:19.270 |DBReply Table TactKey RecID 264 invalid|
|9/27 04:48:19.692 |DBReply Table BroadcastText RecID 155771 valid|

I do not know anything about how these files work or how the game works from a technical point of view so I do not know what this means. Is it normal? Is it not normal? It seems like an awful lot of lines to write in 1 second.

It might be completely irrelevant but the reason I include it is because as i mentioned, once I linked the Logs folder to a folder on my desktop instead of using the one the game provides in the installation folder, most of the freezes disappear. Cache, WTF and GPUCache do not change anything individually, but the Logs folder does.

So it really feels like the lag and freezes we experience are caused by log writing on slow connection, low speed or broken drives.

3 Likes

I feel sorry for Blizzard just reading so many dumb comments here.

Thanks for working on the issue and providing us with a beautiful world for over one and a half decade.

Really appreciate you all!

Once again sorry for the dumb idiots posting constantly negatively just because there is an issue for a while.

Things I tried to do(not having an SSD) but didn`t fix it:

  • Reinstall the game
  • Put the WTF + INTERFACE folder out & deleted the CACHE folder
  • Played without any addons

It still has a lag whenever turning in a quest.

3 Likes

It seems for me at least, it works also to just turn off all access permissions on the Hotfix log file in your Logs folder.

Go to your Logs folder, right click the Hotfix file.
Click Properties>Security>Select Everyone then >Edit.

Check “Deny” on everything, then hit apply.

If nothing else has worked for you, you should try if this works.

4 Likes