Stuck on quest: Word from Orsis

I am stuck on the quest: “Word from Orsis” during the Aqir assault in Uldum. I can’t pick up the water bottle next to the NPC “Laborer Mitchell”.

And oh, the in-game bug-report tool just sends you in a circle, making it impossible to report any bug on the issue.

To report a bug in-game:

  1. Press Esc or click the ? button to open the menu.
  2. Click Support.
  3. Click Submit feedback or bug report.
  4. Enter the details of the bug into the Submit a bug description box, making sure to follow the guidelines outlined on the submission form.
  5. Click Submit.

Thanks that did the trick :slight_smile:

I also submitted a bug report for this issue.

I’ve submitted a bug report for the issue and have not been contacted back by Blizzard/Wow developers. I’ll keep submitting new ones until we get a response :smiley:

I believe the issue is you have to complete the Assault: Aqir Unearthed Active after that, the bottle will become active. I’ll confirm and post back for anyone else in the same situation.

1 Like

I reported this to a GM and got a bemusing reply telling me to turn on War Mode or join a random grp lol. Needless to say those didn’t work.

But I tried what you suggested Nocty. I completed the Assault, handed in everything then went back to the collapsed NPC and I still can’t click the bottle. Did the usual turning off all addons, reload, exit game and still nothing.

You could still be right though in that it’s a bug related to this PARTICULAR assault. I will try and come back on a different assault although I wont hold out too much hope as it would be an assault not related to this quest…but worth a shot right?
Will post back if it works.

So, I was wrong. I thought it was due to the Assault not being active, but it’s active right now and is still not working.

That’s interesting about the war mode on and joining a group. Haha. Sorry for the confusion. I’ll continue to report it. :slight_smile: