Title automatically gets unequipped when logging in

Everytime I log in on my shaman specifically I log in with no title equipped, even though I logged out with one. It also gives me the animation as if I just levelled up when I log in.

Has anybody else had a similar experience? And if so, did you fix it and how?

Just some additional information;

  • It is only on my shaman, every other character is fine.
  • I recently used the barbershop in Valdrakken, it’s been happening since.
  • Everytime I log into the character, I get the animation as if I’ve levelled up or learned a pet/toy/mount
  • I have tried to disable all addons, and unequip all gear and it didn’t fix it. I also emptied my quest log.

yes. me too. I spent weeks farming “The Insane” title just for it to not show up to others?!. uncool.

1 Like

cool guy i approve of ur post… blizzzard what u thinking? pls responmd this man fast… i have same issue bro

same issue with any title since 2 or 3 days, replying so that blizz may see it’s a common issue among users now

Yes! I have the exact same problem and glad to see I’m not the only one. Only applies to the one level 70 character I have. I log in, there is the level up animation and my title has been switched off.

Have yet to encounter this problem on my alts but none of them are yet to reach Dragon Isles, so if the problem is somehow related to that, it may be the reason why.

This is a minor annoyance tbh but one I’d sure like fixed.

To add a thing I just noticed, sometimes the title is switched off during gameplay WITHOUT logging out. What triggers this I do not yet know for sure, but it at least seems that if I go afk the title seems to disappear as the “Away” appears to my name.

Having the exact same problem only on the character that I completed the Dragonflight campaign on. The others dont have this issue.

It’s happening on my Evoker now aswell, who has not finished the full campaign yet.

Same issue for me too, thought maybe it started happening after I was disconnected (from my dragonriding mount flying into a small fire…)

Yep, same for me. Very annoying.

Same here, but it only seems to be in Dragonflight zones.

Yep, same here. past few days on my main Tórsten, every other character is fine.

Having the same issue, title vanishes upon login but only one the one character.
To those having the issue - sorry to hijack the thread away a mo - are you able to disable addons?
Trying to see if the two are linked ie losing title and not being able to disable addons on that particular character.
Thanks :slight_smile:

Tried disabling the addons immediately when I noticed the bug. It’s NOT an addon issue.

EDIT: I’ve had no problems disabling addons.

I’m not saying it is, i’m asking to those that lose their title can they disable addons? I’m having issues only on this toon disabling them and issues with losing the title, i’m trying to see if the two are part of the same issue or seperate

Seems like they are separate issues (according to my experience so far).

Update: still happening, now on all my characters too. It’s a Dragonflight thing at level 70, was not a problem at any level prior to it.

All characters i login in to have their title reset.
When re-selecting a title it is gone after a full logout + login. Like back to the character screen.

When i simply reload my ui the title sticks.

Wanted to make a thread myself and then found this one.

problem still persists

for me still only on the one i leveled during the first week and got dc’d

I have been having the same problem, but my boyfriend doesn’t. I wonder if it’s because he’s using an old title from before DF