Unable to buy paid transfer to Hydraxian Waterlords

See Title.

It seems this server is having issues of some kind, as it throws the same error (see below) as if you try to transfer to a full server like Firemaw.

“The selected realm is not accepting character transfers at this time.”

So not only is the free transfer broken from full servers, but it also seems you just can’t transfer there from anywhere at the moment.


I really don’t know whether to laugh or to cry. It’s just kind of frustrating at this point.


This is for sure not intented.
The difficult quest is:

Find someone who can pass on the information that something is completely wrong with the transfers to Hydraxian Waterlords…

1 Like

But it is still not working.

Hi Hyperpop. This is likely linked to the free transfer situation.

Please refer to the free migration thread for eventual updates:


They fixed the free transfers a couple days ago but there’s been no word about Paid Transfers to HW getting fixed, is that on the cards to be done before WOTLK release?

1 Like

I have been trying to do the same from Pyrewood to Hydraxian for a week now.

1 Like

I wake up everyday and test it but at this point I think Blizzard have just forgotten about it.

Any luck yet? Trying to pay to leave Hyrdaxian Waterlords but keep getting errors, payment taken though, blizzard are clueless and nobody is helping me.

1 Like

Stuck on Pyrewood for a week. Blizzard took my money 2 times and now I just get an error

Same thing happening for me Firemaw->Earthshaker, inital transfer failed, and now I cannot use the service anymore. I’ve been talking to GM’s for days but no results.
Could it be that the cooldown was triggered even thou there was no transfer and now we need to wait 90 days to use it again ?

1 Like

Still happening for me. Sigh.

GG Blizzard locked my destination server after a month of trying to transfer. Friends and guild all transfered already.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.