Voice chat connecting by itself after forming a party


#1

Few days ago I had a very weird experience with the voice chat service in game. I never use this feature and I do everything I can to avoid it to connect since I really don’t want any voice communications with strangers in the game, ever. I use discord with guildies.

I joined a pug for an m+ run and I didn’t really notice anything strange, until I heard people talking from my speakers… Let me be straight here, after I realized what’s happening I was furious. The voice chat connected without any form of consent or interraction from me. And I don’t find connecting the game to my microphone as a light issue, I take this as an extreme breach of privacy.

I opened a ticket and got a message from a GM few minutes after. Kudos to the guy, he really tried to help me, tried to talk me through settings etc. In short, he told me addons, driver updates, OS updates or so can mess with the settings too and there was no hotfix 48h prior to the day we chatted so everything is fine and there’s nothing he can do.

I came to the conclusion this was a bug, because… recap of events:

Before the day voice chat started to connect:

  1. I had two buttons by my main chat window, both were crossed out with a red line. (to disable microphone and speakers)
  2. My settings in game for microphone: microphone on default, sensitivity 0%, push to talk settings with riddiculous ctrl+alt+shift+F12 push to talk button.
  3. My settings in bnet app for microphone were the same settings as in game.
  4. I never got any error messages in chat, or red on screen about trying to connect to voice chat when joining a group.

On the day the voice chat started to connect by itself:

  1. Two crossed out buttons by chat window for mic and speakers are gone.
  2. settings in game for mic and speakers are as I set them
  3. settings in bnet app for mic and speakers are resetted to default.
  4. My nameplates are small (default settings) - this is random, but I always have them as larger nameplates and it looked as reversed to default settings.
  5. On this day I updated a few of my addons. Didn’t update any drivers, or get a win update.
  6. when joining a party, everytime I got a red text on screen about waiting for person from another server to connect to voice chat and in chat window pretty much about the same thing. (the party was always cross server, and I was never the leader.)
  7. When I opened the window for voice chat, the speakers button was not working at all, as if it was fixed just on being connected and there was nothing I can do to turn it off when in a party.

The day after (and after the chat with a GM):

  1. The two buttons for disabling mic and speakers by main chat win are back, crossed out.
  2. in game settings for mic and speakers are ok, not resetted.
  3. bnet app settings for mic and speakers are ok, not resetted (after me chaging it to disable the mic again).
  4. When forming a group, I didn’t get any messages about trying to connect both has a leader and not leader of the group.
  5. I didn’t update any addons since the incident, nor drivers, win update, and I didn’t reinstal the whole game as I was planning to.

Basically, it seems the issue fixed itself, or it was hotfixed.

I’m reporting this here because this is a serious issue and I don’t think a game should connect to my microphone without my consent. I really hope you can prevent this from happening again.