Weird phasing/instancing on the dragon isles?!

Hey, i’ve started playing DF with a friend today. The problem came right away after leaving the ship. We are in different instances and can’t find a way to play together. Here the things we tried so far:

  • rejoining party
  • start party sync
  • relogging
  • creating a group via party finder (the partys we create are not listed for the other person)
  • going back to Stormwind and taking the ship once again together while in a party

Any help would be appreciated!

Has one of you done some quests in DF the other hasn’t?

That’s the only thing I can think of - that different progress has put you in different phases. But it sounds wrong to me that phasing would apply straight from the initial landing.

Have you tried both setting War Mode Off before you get teh ship, then travelling, and then both setting War Mode On before you leave SW?

This sounds like question the regulars in Technical Support forum might have seen before, thogh I don’t see any recent reports. Maybe ask there?

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.