WoW launching very slow after new GPU

UPDATE: I tried leaving it on for several minutes, apparently it takes very long to render everything. The game started showing after several minutes (5 to 7 minutes) and it appears that everything in-game is also rendering very slow as in chat icons, my character doesn’t appear when I mount up for several seconds, etc. etc.

I tried closing WoW and re-opening it to see if it only took a long time to start up for the first time, but unfortunately it is everytime that I start up the game.

Does anyone know what I can do here?


I bought a new ASRock Radeon RX 6800 XT Taichi X 16G OC which I installed yesterday, and for some reason after I installed the GPU my WoW does not work anymore.

When I click on play, the game runs and I can see the WoW logo in my taskbar on the bottom of my screen, I even see the WoW cursor (the silver hand thing) and hear in login screen / character select music, but WoW itself does not appear on my monitor.

I have tried re-installing, scanning and repairing and resetting the in-game settings through the BNet launcher, tried removing the file in my WTF folder and I still have the same problem, all my drivers are up-to-date as well.

Does anyone know how I can solve the issue?

try downloading display driver uninstaller and running that, then reinstall drivers.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.