Schermo in protezione ad ogni avvio

Da qualche giorno tutte le volte che avvio il gioco lo schermo del monitor mi entra in protezione…. Durante la schermata di caricamento tutto ok, appena il gioco arriva alla schermata principale, lo schermo si spenge. Per riuscire a giocare devo fare ALT-TAB e spengere e riaccendere il monitor… e noto che la finestra di Battle Net non mostra il contenuto, come se il task fosse andato in errore.
Ho già provato a disinstallare (con DDU) e reinstallare i driver della VGA.

Baio

Ciao Baio73, scusa se ti rispondo solo ora ma la mia salute m’ ha mollato a piedi per qualche giorno ;
potresti cortesemente mettere qui i due file informativi del sistema? https://eu.battle.net/support/it/article/12988 (Dxdiag; MSinfo) usa un sito come “Pastebin” per pubblicare i files, per favore, e poi incolla qui il link per visionarli; a presto!

a me appena entrava il personaggio nel gioco si freezava l’immagine, poi riavviando faceva la stessa cosa, prendendo un altro personaggio non me lo faceva, poi riprendendo il personaggio di prima andava tutto liscio, cioè dovevo entrare nel gioco prendere un personaggio a caso poi uscire dalla partita e prendere il personaggio che mi interessava, cosa stranissima, che non riesco a motivare…

Ciao,
Grazie per la risposta.
Purtroppo il sito non mi consente di includere link nei miei messaggi…
Ne approfitto per rimarcare che questa versione del forum è una pena totale.

Baio

Il nuovo forum suddivide gli account in livelli. Più lo utilizzi, più il tuo livello sale, più sono le funzioni che puoi avere nello scrivere i messaggi, come ad esempio proprio il postare link a siti esterni o immagini e gif.

In ogni caso, i link possono anche essere postati inserendoli con l’opzione </> che vedi nella finestra dei messaggi.

Non me li fa postare neppure con </>…
Quindi mi tocca iniziare a spammare messaggi a caso solo per salire di livello?
Il tutto per avere una risposta di carattere tecnico?
Dio mio…

Baio

E quando si sbloccano ste funzioni? 1000 messaggi?!?

1 "Mi piace"

Mi sembra strano che tu non possa farlo, considerando che per tutti gli altri utenti la cosa funziona… ma a questo punto ti basta scrivere il link in maniera “creativa”: senza punti, con spazi di troppo, con una A prima dell’http ecc.

Si trova facilmente una guida digitando su Google Discourse Trust Level, ma i requisiti lì indicati sono quelli massimi e la Blizzard potrebbe averli modificati per renderli più accessibili.
Di base basta solo frequentare il forum in maniera attiva: scrivere e leggere post, aprire discussioni, mettere mi piace… le solite cose che chiunque farebbe normalmente.

2 "Mi piace"

Sulla guida che mi hai indicato dice che il livello del account viene visualizzato nella mia schermata. Ora,o sono io rincoglionito oppure questo indicatore non è presente da nessuna parte…

La seconda che hai detto, quindi tranquillo che ancora ragioni bene. :stuck_out_tongue:

Ps: ti ho mandato una richiesta d’amicizia, non so se ti sia arrivata.

In realtà ho sempre scritto e usato uno smartphone per frequentare il forum. Non ho un pc e quindi non so dove arrivino le richieste :joy:
Non sei il primo in questi anni che me lo dice :sweat_smile:

Ci riprovo:

DxDiag accatitipislashslashpuntopastebinpuntocomslash4fmzVB6T

MSinfo accatitipislashslashpuntopastebinpuntocomslashAjeSeqdG

Baio

EDIT:
Ho scollegato la tastiera (la tenevo collegata all’hub USB integrato nel monitor), adesso la procedura è questa: lancio Diablo e arrivo alla schermata principale, appena muovo il mouse il monitor va in protezione, faccio CTRL+ALT+CANC, spengo e riaccendo il monitor e torno al Desktop. A questo punto se clicko nuovamente sulla finestra di Diablo riesco a giocare.
Cercando in giro ho trovato riferimenti ad un problema con la VGA (nVidia però), ma DDU/reinstallazione l’ho già fatto.

Ciao di nuovo Baio; hai controllato di aver impostato il tuo monitor come primario nelle impostazioni grafiche del desktop?
Hai il software Adrenaline istallato?
Che risoluzione usi per il gioco?
Hai schermi secondari, HDMI hub o altro attorno al monitor principale?
Bravo; per la soluzione temporanea che hai trovato.

Ciao,
Purtroppo il “workaround” che ho trovato ha funzionato per poco…
Il problema è collegato sicuramente ai driver della VGA (sto scaricando l’ultimo update) ed al cambio di risoluzione fra le varie schermate del gioco. Mi si è piantato il pc due volte (BSOD) con l’errore VIDEO_SCHEDULER_INTERNAL_ERROR, un altro paio di volte tornando al desktop ho trovato una finestra di errore riferita alle DirectX (qualcosa tipo “impossibile avviare D3D”).

Provo i driver nuovi, per sicurezza passo prima DDU.

Baio

Ok, buona fortuna, nel caso , prova i passaggi che ti ho indicato anche col nuovo driver grafico e assicurati di avviare il gioco sul monitor primario e di non avere altre device hub USB o HDMI collegate al monitor; attualmente stavo esaminando il Dxdiag… sembra ci siano problemi coi file di kernel; ti aggiorno appena possibile.

Ps: se hai Xbox gaming app aperta in background ricordati di spegnerla e disattivarla o cancellarla temporaneamente, così anche con altre eventuali app in background…

Allora… i driver nuovi si comportano esattamente come i vecchi… ho disabilitato la barra XBox ma anche quello non ha portato miglioramenti.
Il monitor è l’unico che ho, non ho hub HDMI o altro… ho solo un altro pc collegato allo stesso monitor, ma c’è sempre stato e non ha mai comportato problemi. Il pc da cui gioco è collegato alla porta miniDisplay, l’altro pc con una normale HDMI.
La risoluzione a cui gioco è 2560x1440@60Hz, che è la massima supportata dal monitor. Ho provato anche a vedere se Dell ha un driver più aggiornato ma non c’è… ed il problema non si risolve neppure col driver generico di Windows.

Grazie ancora per la pazienza.

Baio

Assicurati di avere la stessa risoluzione anche sul desktop di Windows per cominciare; poi prova a staccare temporaneamente l altro pc per favore.
Infine , prova ad avviare il gioco così: Cerca questo file colla funzione cerca di Windows : " D3Prefs.txt " ; aprilo con un editor di testo e cerca questa linea modificando il valore così: DisplayModeWindowMode"1" salva ; chiudi. e riavvia tutto ; se entri in gioco , apri il menù principale delle opzioni e vedi se la sincronia verticale è abilitata o meno e fai delle prove con relativi riavvii del gioco(…in un secondo tempo fai un check anche nelle opzioni del manager della tua scheda grafica per controllare la sincronia e altre opzioni)!

Pps: dai un occhiata qui riguardo all errore: “VIDEO_SCHEDULER_INTERNAL_ERROR”
https://www.drivereasy.com/knowledge/video-scheduler-internal-error-on-windows-10-solved/

  1. Le risoluzioni sono identiche fra Windows e Diablo. In game ho la possibilità di settare anche risoluzioni maggiori, avendo abilitato dal pannello di controllo Radeon la Virtual Super Resolution, ma anche disattivandola non cambia niente… anzi peggiora, nel senso che il monitor si spenge addirittura durante la schermata di caricamento.

  2. Avviando il gioco dopo aver editato il file D3Prefs.txt mi ha avviato il gioco in finestra. Ho provato ad impostare nuovamente lo schermo interno ma al successivo riavvio del gioco stessa solfa. Adesso il valore è tornato a “0”.

  3. La sincronia verticale nel gioco è disabilitata, è abilitata l’opzione “Sincronizzazione Ottimizzata” dal pannello Radeon.

  4. Scollegare il secondo pc non ha cambiato niente.

  5. Quel sito l’avevo trovato anche io ma non mi pare che offra soluzioni che non abbia già provato.

Baio

EDIT:
Abbiamo trovato l’arcano… è il settaggio “Sincronia Ottimizzata” del panello di Controllo Radeon. Hp attivato il VSync “classico” dalle opzioni sia Radeon che del gioco ed ora funziona perfettamente.
Il bello è che si tratta di un’opzione che appena installi i driver AMD in automatico il sistema ti consiglia di attivare…

Grazie mille per la pazienza!

Bene!
Lieto di averti indirizzato verso la soluzione che hai trovato; Buon gioco! :slight_smile:
Grazie della tua collaborazione e dei dati forniti, argomentare al massimo un problema fornisce spesso buoni spunti(ad esempio qui ci ricordiamo di controllare sempre le opzioni del manager grafico che spesso variano/si resettano con una istallazione di un nuovo driver e/o app che gestisce la grafica/le opzioni grafiche) !

Ho provato anche con un altro pc, attivando l’opzione “Sincronia Ottimizzata” dal pannello Radeon il gioco funziona normalmente, però in questo pc ho una RX460, su quello dove ho il problema ho una 5700XT.
Spero vi sia utile.
Grazie di nuovo.

Baio