Crash del gioco al click sulla sezione "Forzieri"

Ciao,
ultimamente sto avendo a che fare con un problema abbastanza insolito all’interno di HoTS.

Come indicato nel titolo, il gioco funziona pressochè bene (a parte alcuni momenti di freeze, seguiti da black screen…?) ma il vero problema è un altro.

Infatti andando in qualsiasi modo a cercare di aprire un forziere, anche quindi quando ne ottengo uno da una ricompensa o da un aumento di livello qualsiasi, il gioco entra in freeze per circa 20 secondi, per poi crashare.

Il problema rimane nonostante abbia preso e reinstallato da zero il gioco per ben 2 volte e non ho cambiato alcuna configurazione da quando ho sperimentato i primi problemi del genere.

Consigli?

Ciao TheMask,

Il problema che stai riscontrando sembra possa essere causato da drivers video obsoleti, ti consiglio pertanto di provare innanzitutto ad aggiornarli.

Nel caso in cui il problema persistesse segui anche i passaggi indicati presso questa guida.

Ciao Nhimoreny,
ho seguito i tuoi consigli, ma la situazione non è cambiata molto.

Ho messo tutti i settaggi audio e video al minimo.
Ho trovato aggiornamenti per alcuni driver, ma niente che riguardasse audio o video.

Il gioco crasha sempre andando ad aprire un forziere, mentre (scoperto da poco) provando a selezionare come modalità “Rissa”, tende a bloccarsi sulla pagina.

Al crash della sezione “Forzieri” il messaggio che appare è “e_gfxErrorApiError”, allego anche l’id se può essere utile: AF0EAB59-C27E-4685-9002-3858317BBD58

Grazie per l’aggiornamento!

Ti chiederei a questo punto di inviarci una copia dei tuoi files diagnostici.

Assicurati di caricarli su di un sito esterno (come ad esempio Pastebin) e scrivere poi l’url nella tua risposta.
Assicurati di impostare l’url come “testo preformattato” tramite il tasto </>.

Ecco qui i file:

  • DxDiag (https://pastebin.com/QE9iwkG3)
  • MSInfo part 1 (https://pastebin.com/jAu1czrf)
  • MSInfo part 2 (https://pastebin.com/PrTDrRV4)

Ho diviso MSInfo in 2 parti poichè troppo grande per un solo pastebin.

Attendo nuove, grazie.

Ciao TheMask, grazie mille per i file!

Ho controllato il tutto e vorrei chiederti di fare alcuni specifici passaggi nuovi, e rifarne alcuni che ti sono già stati suggeriti.

Parlando di questi ultimi, devo chiederti di ricontrollare per eventuali aggiornamenti driver per la tua scheda video. L’ultima release disponibile di tali driver da parte di Intel è di pochi giorni fa ed è molto strano che tu non sia riuscito a trovarne, ti chiederei quindi di provare seguendo questi specifici passaggi:

  • Accedi alla pagina di supporto Intel tramite questo sito
  • Clicca su Introduzione
  • Scarica ed esegui il programma Intel Driver & Support Assistant
  • Segui poi le istruzioni che ti saranno presentate per permettere al programma di fare una ricerca per eventuali aggiornamenti
  • Scarica ed installa qualsiasi aggiornamento che ti sarà indicato

In alternativa puoi provare a scaricare direttamente il pacchetto driver da qui. Non posso però assicurarti che sia il piú adeguato per il tuo sistema (alcuni portatili hanno bisogno di driver particolari).

Una volta aggiornati i driver procedi poi come segue:

  • Riavvia il pc in modalità avvio selettivo
  • Assicurati di aver completamente disattivato la funzionalità Game DVR di Windows. Trovi dettagli in proposito qui
  • Disinstalla il programma SmartByte

Completato il tutto prova poi nuovamente a lanciare Heroes e vediamo se ci sono miglioramenti ^^

Ciao Felnarys,
sono riuscito a sistemare finalmente: eseguendo la procedura che mi avete consigliato, ho notato che i driver video del pc erano stati customizzati e non erano sviluppati da Intel, bensì da Dell.

Installando i driver corretti e finito tutto quanto, avviando il gioco infatti andava tutto stavolta.

Grazie mille a entrambi per il supporto in questi giorni!
Ciao

Grazie per l’aggiornamento. :slight_smile:

Siamo felici il problema sia ora risolto. Buona fortuna con l’apertura dei forzieri!