Ständig Lags und Verbindungsabbrüche

Ich habe immer wieder erhebliche Lags und gefühlt in jedem 2. Spiel einen Verbindungsabbruch.
Hier 2 WinMRTs. 1. ganzes Spiel mit Lags, 2. während eins Verbindungsabbruchs.

w/o connection loss but laggy
|------------------------------------------------------------------------------------------|
|                                      WinMTR statistics                                   |
|                       Host              -   %  | Sent | Recv | Best | Avrg | Wrst | Last |
|------------------------------------------------|------|------|------|------|------|------|
|                               fritz.box -    0 |  494 |  494 |    0 |    0 |    8 |    1 |
|                            213.157.2.17 -    1 |  493 |  492 |    5 |   10 |  100 |   13 |
|                   ae17.ju7001.net-mn.de -    0 |  494 |  494 |    4 |   11 |  100 |   18 |
|                    ae1.ju7004.net-mn.de -    0 |  494 |  494 |    4 |   11 |   97 |   26 |
|           pr01.eqfr5.blizzardonline.net -    1 |  493 |  492 |    5 |   12 |  100 |    7 |
|              ae1-br01-eqfr5.as57976.net -    6 |  457 |  433 |   10 |   49 | 4005 |   38 |
|         et-0-0-2-br01-eqam1.as57976.net -    9 |  431 |  393 |   10 |  152 | 4722 | 3092 |
|                           137.221.65.75 -    7 |  448 |  419 |   11 |   92 | 4497 | 3519 |
|                           137.221.78.47 -    1 |  490 |  487 |   10 |   15 |  144 |   11 |
|                           137.221.66.41 -    1 |  493 |  492 |   10 |   13 |   60 |   11 |
|                          185.60.112.158 -    1 |  493 |  492 |   10 |   13 |   61 |   11 |
|________________________________________________|______|______|______|______|______|______|

|------------------------------------------------------------------------------------------|
|                                      WinMTR statistics                                   |
|                       Host              -   %  | Sent | Recv | Best | Avrg | Wrst | Last |
|------------------------------------------------|------|------|------|------|------|------|
|                               fritz.box -    0 |   13 |   13 |    0 |    0 |    3 |    0 |
|                            213.157.2.17 -    0 |   13 |   13 |    5 |    6 |    9 |    5 |
|                   ae17.ju7001.net-mn.de -    0 |   13 |   13 |    4 |    6 |    9 |    8 |
|                    ae1.ju7004.net-mn.de -    0 |   13 |   13 |    4 |    5 |    9 |    5 |
|           pr01.eqfr5.blizzardonline net -   58 |    7 |    3 |    0 |    6 |    7 |    5 |
|              ae1-br01-eqfr5.as57976.net -   58 |    7 |    3 |    0 |   23 |   46 |   46 |
|         et-0-0-2-br01-eqam1.as57976.net -   58 |    7 |    3 |    0 |   12 |   12 |   12 |
|                           137.221.65.75 -    0 |   13 |   13 |   12 |   16 |   57 |   13 |
|                           137.221.78.47 -   58 |    7 |    3 |    0 |   11 |   13 |   11 |
|                           137.221.66.41 -   58 |    7 |    3 |    0 |   12 |   13 |   12 |
|                          185.60.112.158 -   58 |    7 |    3 |    0 |   11 |   12 |   11 |
|________________________________________________|______|______|______|______|______|______|
   WinMTR v0.92 GPL V2 by Appnor MSP - Fully Managed Hosting & Cloud Provider

Die gleichen Probleme gibt es bei anderen Rechnern im Haushalt.
Ähnliche Probleme gibt es bei WOW.

Keine Probleme mit anderen Internetdiensten und Spielen.

https://eu.forums.blizzard.com/en/overwatch/t/as57976-net-packet-loss/12161

Hmm, scheint schon mal vorzukommen. Wäre tolle wenn blizz das auch selbst überprüfen würde. Ich hatte eigentlich gehofft, dass das der Fall ist, aber das problem besteht schon seid geraumer Zeit und wird eher schlimmer als besser.

Hallo Milo,

Verbindungsabbrüche und Lags sind sicherlich sehr ärgerlich und da alle Systeme im Haus Probleme zu Blizzarddiensten haben, bedeutet das wahrscheinlich, dass es ein Problem auf der Route zu unseren Servern gibt.

Um dies zu testen, würde ich dir raten, temporär eine andere Verbindung zu nutzen, wie beispielsweise über ne Handyverbindung oder nen VPN.

Gruß,

Dresiaron

Hallo Dresiaron,

hast Du dir die MRT-Ausgaben angeschaut? Paketverluste entstehen ab den Servern in euerm Netz. Bis zu eurem Netzt (ich nehme an ´blizzardonline.net´ hat was mit blizzard zu tun) sind die Pings zwar nicht super, aber doch ok. Ab da wirds deutlich schlechter. Viele Packetverluste und z.T. sehr schlechtes Antwortverhalten (Wrst Ping von >4000). Besonders interessant: zur Zeit eines Verbindungsabbruches sind die Ergebnisse von WinMRT in euerem Netz unterirdisch (kanns nicht anders sagen) bis zu euch aber unverändert.

Ich kann nicht ganz nachvollziehen wie Du bei der „Beweislage“ darauf kommst, dass es an der Route zu euren Servern liegt. Das Problem liegt definitiv bei bzw hinter ´as57976.net´ und eine internetsuche sagt, die Domain gehört „Blizzard Entertainment, Inc“.

Also bitte!

Hallo Milo,

zunächst möchte ich dir für die Ergebnisse der WinMTR-Tests danken.
Leider sind die Zweiten Ergebnisse nicht wirklich aussagekräftig, weshalb ich mich ausschließlich auf das erste Ergebnis konzentrieren werde.

Diesen Punkt muss ich näher Erläutern, da die Ergebnisse, welche du da vorfindest, in der Tat etwas irreführend sind.

Diese hohen Zahlen (grün markiert) entstehen dadurch, dass diese Testpakete innerhalb der Serverinfrastruktur von Blizzard mit einer deutlich niedrigend Priorität behandelt werden. Daduch kann WinMTR schonmal auch Paketverlust anzeigen, obwohl gar kein Paketverlust vorhanden war.

Bevor wir noch tiefer in die Fehlersuche gehen, würde ich dich bitten in den Einstellungen deiner Fritzbox zu kontrollieren, ob dein PC die höchste Priorisierung hat (oder überhaupt eine Priorisierung).
Wie das funktioniert kannst du hier nachlesen: https://www.giga.de/hardware/fritzbox/tipps/fritzbox-internet-bandbreite-zwischen-geraeten-priorisieren-so-gehts/

Hast du die Priorisierung eingestellt, führst du bitte noch einmal einen WinMTR-Test durch und postest die Ergebnisse anschließend wieder hier.

Freue mich über Feedback

gemcht:

|------------------------------------------------------------------------------------------|
|                                      WinMTR statistics                                   |
|                       Host              -   %  | Sent | Recv | Best | Avrg | Wrst | Last |
|------------------------------------------------|------|------|------|------|------|------|
|                               fritz.box -    0 |   48 |   48 |    0 |    0 |    9 |    0 |
|                            213.157.2.17 -    0 |   48 |   48 |    5 |    8 |   55 |    6 |
|                   ae17.ju7001.net-mn.de -    0 |   48 |   48 |    5 |    8 |   57 |   57 |
|                    ae1.ju7004.net-mn.de -    0 |   48 |   48 |    5 |   12 |   80 |    5 |
|           pr01.eqfr5.blizzardonline.net -    0 |   48 |   48 |    6 |   12 |   67 |    7 |
|              ae1-br01-eqfr5.as57976.net -   23 |   35 |   27 |   11 |   31 |  427 |  427 |
|         et-0-0-2-br01-eqam1.as57976.net -   20 |   35 |   28 |   11 |  188 | 2766 | 2766 |
|                           137.221.65.75 -   11 |   39 |   35 |   12 |  210 | 4268 | 4268 |
|                           137.221.78.47 -    0 |   48 |   48 |   10 |   13 |   76 |   12 |
|                           137.221.66.41 -    0 |   48 |   48 |   11 |   11 |   15 |   12 |
|                          185.60.112.158 -    0 |   48 |   48 |   10 |   11 |   15 |   11 |
|________________________________________________|______|______|______|______|______|______|
   WinMTR v0.92 GPL V2 by Appnor MSP - Fully Managed Hosting & Cloud Provider

Hmm, und bei den Servern dahinter ist das nicht mehr der Fall?
Egal, bis Blizz sah es jedenfalls gut aus.

Warum? Das war exact während eines Verbinungsabbruchs bis zum Wiederverbinden. Die Abweichungen der beiden Logs (erhebliche Packetverluste und deutlich schlechtere Zeiten während des Verbindungsabbruchs) legen nahe, dass der Grund für den Verbundgungsabbruch und das herunterpriorisieren der Test-Pakete zeitlich sehr eng zusammen liegen. Da könnte es ja schon einen kausalen Zusammenhang geben.

Insgesammt: Das Problem liegt nicht zwischen unserem Heimnetz und den Blizz Servern.
Das Problem liegt auch nicht an meinem Rechner (zumindes das nicht :frowning: , und ich sehe auch keinen Anhaltspunkt, dass es in unserem Heimnetz liegt.

Aber dass es im Blizz-Netz Probleme gibt, dafür sehe ich in den Logs doch mindestens deutliche Indizien. Am Ende will und kann ich ja auch nicht das Netz von Blizz analysieren (und du sicher auch nicht). Aber aus den Logs auf

zu kommen :face_with_raised_eyebrow:

Ach … Ab blizzardonline.net fangen bei mir die Blizzard Server an, auch wenn das sicher noch ne Menge Netzwerkinfrastruktur ist.

Und dann noch Danke für die Zeit und Mühe die Du hier investierst!

Ganz einfach: 13 gesendete Pakete sind einfach viel zu wenig um eine ansatzweise vernünftige Analyse vornehmen zu können.

Das gleiche ist es mit deinem jetzigen WinMTR-Ergebnis:

So ein WinMTR-Test sollte in der Regel ca 15 - 20 Minuten laufen.
Nur so bekommt man wirklich aussagekräftige Ergebnisse.

Aber um dir das mal näher zu erläutern, schau dir doch mal das letzte WinMTR-Ergebnis an. Du hast von deiner Fritzbox aus 48 Pakete versendet.
Schaust du nun auf den Heroes of the Storm Server (das ist die letzte IP) sind dort auch 48 Pakete angekommen.
Das bedeutet also, dass zwischendurch keine Pakete verloren gegangen sein können, trotz dessen, was hier angezeigt wird:

Warum ihr trotzdem mit mehreren PC’s diese Lags habt, kann viele Ursachen haben.
Um hier genauer helfen zu können wären folgende Informationen wichtig:

  1. Bei welchem Provider seid ihr?
  2. Was für einen Internetanschluss habt ihr (Kabel über Multimediadose oder DSL über Telefondose?)
  3. Was für eine maximale Bandbreite steht euch zur Verfügung.
  4. Wie viele Geräte greifen gleichzeitig auf das Netz zu (bei Kabelanschluss inkl. Fernseher)?

Das sind ein paar Faktoren, welche erheblichen Einfluss haben können.

Warum?

Ich habe „ab und an“ Verbindungsabbüche. Wenn ich da ein traceroute für ne halbe Stunde laufen lasse, am besten noch ohne Verbindungsabbruch, erfahre ich davon schlicht nix. Die Magie der großen Zahlen arbeitet dann gegen mich. Wir suchen hier quasi die Nadel im Heuhaufen, und du argumentierst, das geht nur wenn der Heuhaufen möglichst groß ist.

In dem kleinen Tracerout (den du nicht genauer anschauen willst) sieht man, dass auch der Endserver Packetverluste hatte (3von7). Oh Wunder … das war ja auch während eines Verbindungsabbruchs.

Ich lass mittlerweile WinMRT immer mal wieder mitlaufen. Hier eins von nem halben Tag:

|------------------------------------------------------------------------------------------|
|                                      WinMTR statistics                                   |
|                       Host              -   %  | Sent | Recv | Best | Avrg | Wrst | Last |
|------------------------------------------------|------|------|------|------|------|------|
|                               fritz.box -    0 | 1952 | 1952 |    0 |    1 |   29 |    1 |
|                            213.157.2.18 -    0 | 1952 | 1952 |    4 |    8 |   77 |    7 |
|                   ae18.ju7002.net-mn.de -    0 | 1952 | 1952 |    4 |   11 |  149 |   31 |
|                    ae2.ju7004.net-mn.de -    0 | 1952 | 1952 |    4 |   10 |   91 |    5 |
|           pr01.eqfr5.blizzardonline.net -    1 | 1947 | 1944 |    5 |   11 |  123 |    6 |
|              ae1-br01-eqfr5.as57976.net -    3 | 1877 | 1830 |   11 |   36 | 4204 |   12 |
|         et-0-0-2-br01-eqam1.as57976.net -    7 | 1718 | 1610 |   11 |  515 | 4839 |   12 |
|                           137.221.65.75 -    4 | 1834 | 1765 |   10 |  208 | 4751 |   22 |
|                           137.221.78.53 -    1 | 1947 | 1944 |   10 |   14 |  137 |   12 |
|                          185.60.112.158 -    1 | 1945 | 1940 |   10 |   12 |   30 |   11 |
|________________________________________________|______|______|______|______|______|______|
   WinMTR v0.92 GPL V2 by Appnor MSP - Fully Managed Hosting & Cloud Provider

Paketverluste gibt es ab blizzardonline.net, vorher nicht! Und zeitlich passieren die genau dann, wenn das Spiel den Dienst einstellt (siehe kleines log). Und du willst tatsächlich behaupten das liegt nicht an Blizz?

Das habe ich nicht gesagt.

Ich habe versucht dir zu erklären, wann tatsächlich ein Paketverlust auftritt und wann nicht.

Dieses WinMTR-Ergebnis:

ist sehr aussagekräftig.
Hier sieht man in der Tat einen Paketverlust:
Deine Fritzbox hat 1952 Pakete gesendet und beim Heroes of the Storm Server sind 1945 Pakete angekommen.
Der Tatsächliche Paketverlust liegt hier bei gesendeten 7 Paketen.
Bei den empfangenen Paketen sind es sogar 12 Pakete.

Und in diesem Fall hast du auch recht, dass der Paketverlust innerhalb der Serverinfrastruktur von Blizzard zu suchen ist, da alle IP-Adressen zuvor auch die 1952 Pakete gesendet haben.

Ähm … das ist aber anders zu lesen:
Die erste Zeile bedeutet AN die fritz.box wurden von meinem Rechner 1952 Pakete gesendet und davon kamen auch 1952 Pakete wieder zurück. Verlust = 0.
Die letzte Zeile bedeutet mein Rechner hat an 185.60.112.158 1945 Pakete gesendet, davon sind 1940 Pakete zurück gekommen. Im Prinzip steht in der Auswertung jede Zeile für dich selbst. Schau doch mal bei Wikipedia tracerout nach, da ist das erklärt.

Ich werte hier nicht den ersten WinMTR-Test aus…
Eine Traceroute ist was anderes.

Fakt ist zum letzten WinMTR-Test, dass deine Fritzbox 1952 Pakete gesendet hat und der HotS-Server nur 1945.

Da ist auf dem Weg dort hin was verloren gegangen.
Nämlich 7 Pakete in Summe.
Deshalb steht vor jeder IP auch eine Zahl in %, was den Paketverlust an dem jeweiligen Knotenpunkt darstellt.

Wenn du weiterhin hier diskutieren möchtest, bist du leider im Falschen Forum.
Für Diskussionen nutzt man das allgemeine Forum.

Wow! Ist das eine Zurechtweisung?

Ich will nicht disskutieren, ich will spielen ohne Lags! Bisher habe ich aber nicht den Eindruck der Sache hier näher gekommen zu sein, oder hab ich was verpasst?

Nein. Es ist ein Hinweis!

Ganz ehrlich… Den Eindruck habe ich nicht.
Und das meine ich wirklich nicht böse!

Ich versuche zu Helfen wo ich kann.

In deinen ersten beiden WinMTR-Tests gab es effektiv keinen Paketverlust.
Nur in dem Letzten ist wirklich einer zu sehen, was ich dir auch bestätigt habe.

Willst du diskutieren? Na gut:
Aus meinem ersten Post:

-> 7 Pakete an den Server gesendet (Sent), 3 Antworten erhalten (Recv), loss von 58%.

493 Pakete gesendet, 492 Antworten erhalten. 1 Paket verloren.

Danke für den Hinweis bzgl. der Router und der Priorisierung der Pakete, und danke dass du mir zustimmst, dass der Blizzard Server Pakete droppt.

Mich würde jetzt interessiere wie mir Blizzard hier helfen will/kann?