Unterirdische Framerate

Guten Abend zusammen,
seit dem letzen Update habe ich extremste Lags in dem Spiel, verwende einen Laptop. Aber nur in dem Spiel. Anno 1800 und D3 lassen sich ohne weiteres spielen. Und vor dem letzten Update war auch Hots kein Problem. Gefühlt habe ich nun alles versucht… Die Grafikeinstellung auf manimalst eingestellt, Energiesparmodus auf Höchstleistung gestellt, Spiel neu installiert, das komplette Hots Verzeichnis (in dem auch die Replays liegen) gelöscht. Ich habe auch geprüft, ob das Spiel über die richtige Grafikkarte läuft oder nur über den Chip…

Ich habe extra zum prüfen diese Xbox Game Bar aktiviert - es scheint, als würde das Spiel - warum auch immer - meine GPU nicht nutzen.

Hier mal die Ressourcennutzung im Menü:
~20% CPU
~ 5% GPU
~18% VRAM
~67% RAM (Firefox (8%) und Discord (5%) sind offen)
~ 4FPS

Im Spiel mit 9 Bots:
~21% CPU
~ 3% GPU
~23% VRAM
~75% RAM (Firefox (8%) und Discord (5%) sind offen)
~ 3FPS

Leider habe ich keine Ahnung, was ich noch versuchen kann. Hilfe wäre sehr nett :slight_smile:
Grüße Frokuss

hab auch ständig mit screen freeze kurz vor tf zu kämpfen. nachdem ich etwas die foren durchforstet habe liegt es wohl entweder am provider, das nicht genügend bandbreite zur verfügung steht oder weil es probleme zw. der festplatte und der hots-sc2engine gibt. hab fest gestellt das das vorbereiten der spieldaten beim start vonn hots aufeinmal auch wesentlich länger dauert

Vielen Dank für deinen Beitrag. „Lags“ war vielleicht der falsche Begriff… meine Framerate liegt permanent bei diesem Wert. Also ist das Spiel völlig unspielbar. Ich habe aber grade mal SC2 gestartet:
~30% CPU
~96% GPU
~10% VRAM
~87% RAM (Firefox (8%) und Discord (5%) sind offen)
~ 61FPS
Hier wird also die Leistung abgefordert.

Da ich auch schon interirdische Frame bei Hots im Menü habe, scheint mir das nicht ein Problem mit der Internetleitung zu sein. Auch hierzu: Habe mit nem Kollegen Anno 1800 zusammen gezockt, ohne dass es irgendwie großartig lagte. Der Providr hat mir auch versichert, dass aktuell keine Störungen vorliegen.

Ich habe dieses Problem erst seit dem letzen Update von Hots.
Gruß Frokuss

Hallo Frokuss,

du hast zwei Optionen, um dieses Problem zu lösen:

1.) Die Grafikleistungseinstellungen in Windows für Heroes of the Storm auf „Hohe Leistung“ stellen (muss nach jedem neuen Update für HotS erneut eingestellt werden)
2.) Du kannst in deinen Treibereinstellungen generell den „Höchstleistungsprozessor“ auswählen, und nicht nur auf’s Spiel bezogen.

Freue mich über Feedback

Vielen Dank für die Rückmeldung,
Punkt 1 hatte ich bereits ausprobiert und hatte zu keiner Lösung geführt.
FÜr Punkt 2 haben ich extra „AMD Radeon Software Adrenalin“ runtergeladen. Auch hiermit erziele ich keine Fortschritte.
Gruß Frokuss

Hallo Frokuss,

Welche Datei aus dem Installationsverzeichnis von Heroes of the Storm hast du hier genau hinzugefügt?
(Gerne per Screenshot)

Am bestens wäre es jedoch, du erstellst eine MSinfo.txt deines Systems.

Diese kannst du bei einem Filehoster deiner Wahl (z.B. pastebin.com oder Googledrive hochladen und anschließend hier verlinken.

Damit du Links posten kannst, nutze bitte die Funktion </>

Vielen Dank für deine Rückmeldung. In der Tat hatte ich die falsche Datei verwendet. Zuerst die exe aus folgenden Verzeichnis
C:\Spiele\Heroes of the Storm, dann
C:\Spiele\Heroes of the Storm\Versions\Base86223
Leider hat auch dies nicht zum erfolg geführt.

Enthält:
ladescreen.png → Ressourcenverbrauch am rechten Rand im Ladebildschirm
menu.png → Ressourcenverbrauch am rechten Rand nach Abschluss des Ladevorgangs
msInfo.txt → liegt auf der Hand :slight_smile:

https://drive.google.com/drive/folders/1285AiYm_O8AKUlAaIjDTX24DyYk7bHxS?usp=sharing

Vielen Dank
Frokuss

Hallo Frokus,

vielen Dank für die Dateien.

Zunächst möchte ich, dass du deinen Autostart aufräumst:

1.) HP Photosmart 5520 series (NET)
2.) EpicGamesLauncher
3.) GIMP Updater
4.) com.squirrel.Teams.Teams
5.) CiscoMeetingDaemon

Diese 5 Programme kannst du meiner Meinung nach im Autostart deaktivieren.

Es ist wichtig, dass du im Autostart wirklich nur die Programme aktiv lässt, welche du auch WIRKLICH benötigst… zu jeder Zeit…


Unter StartEinstellungenSystemAnzeige bitte ganz runter scrollen Grafikeinstellungen fügst du bitte folgende Programme aus dem Installationsverzeichnis von Heroes of the Storm hinzu:

1.) Heroes of the Storm\Support\BlizzardBrowser\BlizzardBrowser.exe
2.) Heroes of the Storm\Versions\Base86223\HeroesOfTheStorm_x64.exe (<— muss nach jedem Update erneut eingestellt werden, da der Versionsorder sich ändert)
3.) Heroes of the Storm\Heroes of the Storm.exe
4.) Heroes of the Storm\Support64\HeroesSwitcher_x64.exe
5.) Heroes of the Storm\Support\HeroesWeb.exe

Jetzt musst du auf jede hinzugefügte Datei klicken und hier Optionen wählen.
In dem sich neugeöffneten Fenster klickst du bitte auf (Höchstleistung).
Die zu verwendete Grafikkarte sollte in der Regel direkt darunter stehen.


Dann würde ich dich bitten folgenden Code in eine neue Textdatei zu kopieren diese anschließend unter dem Namen „Wartung.bat“ abzuspeichern:

@Echo off
sfc /scannow
DISM.exe /Online /Cleanup-Image /Restorehealth
sfc /scannow
ipconfig /release
ipconfig /renew
ipconfig /flushdns
Sc config wsearch start=disable
Net stop wsearch
EsentUtl.exe /d %AllUsersProfile%\Microsoft\Search\Data\Applications\Windows\Windows.edb
Sc config wsearch start=delayed-auto
Net start wsearch
set /p antwort=Um die Wartung bestmoeglich abzuschliessen, muss der PC vollstaendig neugestartet werden! Soll der vollstaendige Neustart jetzt durchgefuehrt werden? (j/n):
if /i "%antwort%" NEQ "j" goto :nein

shutdown /g /t 0
goto :end

:Nein
echo Aktion abgebrochen!

:end
pause

Ist das erledigt machst du bitte einen Rechtsklick auf diese Dateie und wählst „als Administrator ausführen“.

Es öffnet sich die Eingabeaufforderung, welche nacheinander die Befehle in der Datei ausführt.

Dabei wird zu erst das Dateisystem von Windows auf Fehler untersucht und repariert.
Danach wird deine gesamte Windowsinstallation untersucht und repariert.
Jetzt erfolgt noch einmal die Untersuchung des Dateisystem von Windows.

Das kann ein wenig Zeit in Anspruch nehmen.

Anschließend wird deine IP-Adresse erneuert und der DNS-Auflösungscache geleert

Zum Schluss wird noch dein Suchindex von Windows defragmentiert.

Ist alles durchgelaufen wirst du aufgefordert einen Neustart zu machen.
Ich würde dich bitten dieses mit „j“ (steht für „ja“) auf deiner Tastatur zu beantworten.


Jetzt könntest du noch meinen Performance Guide durcharbeiten um sicherzustellen, dass dein Windows wirklich Optimal läuft:

Du könntest auch noch unter StartEinstellungenDatenschutzHingergrund-apps alle Apps auf aus stellen, wo du der Meinung bist, dass du diese nicht benötigst.
Achte aber darauf, dass du nicht alle Hintergrund-Apps deaktivierst!
Einige müssen aktiv bleiben!


Solltest du ein Overlay zum Anzeigen der Ressourcen verwenden, so bitte ich dich dieses zu deaktivieren. Solche Overlays können massive Leistungsprobleme in Heroes of the Storm verursachen.

Freue mich über Feedback !

Hallo Truphoss,
vielen Dank für deine Mühe. Witzigerweise sind die hälfte dieser Programm im Taskmanager aus dem Autostart bereits deaktiviert gewesen.

Dazu habe ich die 4 weiteren Exen auch in den Grafikoptionen hinzugefügt. Ein kurzer Test hat keine Veränderung an dieser Stelle aufgezeigt.

Deinen Batch-Code habe ich auch soweit durchgeführt. Den Anfang manuell, den rest dann doch per Script. Im ersten Scan hat er noch nen Fehler gefunden. Danach schien alles okay zu sein.
Nach dem Neustart habe ich das Spiel mal eben kurz gestartet… Naja, das hat leider alles nichts gebracht.

Die ein oder andere Hintergrund-App hatte ich bereits auch schon deaktiviert.

Wie gesagt, ich habe mit diesem Gerät noch kurz vor diesem Thread noch völlig normal gespielt. Ich habe dieses Problem erst seit dem letzen Update. Und zwar nur in HotS.

Was die Verweise bezüglich des Performance Guide angehen, führen diese irgendwie ins Nirvana.
1.) Ram: virteuller Ram wird von Windows zugewiesen. Scheinbar sind aktuell 15GB reserviert bzw in Verwendung - die Größe juckt mich aber auch nicht sonderbar, noch ist genug Platz da :smiley: Auslagern auf eine andere Platte macht bei genau einer SSD auch keinen Sinn.
2.) Im Gerätemanager habe ich noch mal die Energieeinstellungen der Netzwerkkarte geprüft. Windows kann NICHT die Karte zum Energiespaaren einschläfern…
3.) Windows auf Höchstleistung zu stellen hatte ich bereits vor deinem letzen Post ausprobiert. Leider erfolglos und deswegen wieder rückgängig gemacht.

Viele Grüße
Frokuss

Hallo Frokuss,

vielen Dank für deine Rückmeldung.

Das bloße Hinzufügen reicht nicht aus.
Du musst auch, wie ich es breits schrieb, für jede einzelne .exe die Höchstleistung unter Optionen auswählen.
Nur dann kann es funktioniert.
Standardmäßig ist eingestellt, dass Windows entscheiden soll, welche Grafikkarte verwendet wird.
Genau dass wollen wir ja nicht. Wir wollen die Nutzung der Grafikkarte erzwingen…

Du könntest zudem auch folgenden Artikel abarbeiten:

https://www.amd.com/de/support/kb/faq/dh-017

Hallo Truphoss,

tut mir leid, dass ich mich jetzt erst melde. Ich hatte natürlich alles bereits ausprobiert. Erfreulicherweise konnte ich zumindestens etwas ausmachen woran es liegen könnte. Aufgefallen ist es mir bei dem Spiel „Tribes of Midgard“. Auch in dem Spiel habe ich nun unterirdische Frames.

Nach ein wenig suchen, laufen wohl beide Spiele auf DirectX 11. Also habe ich ein wenig ausprobiert. Bei Anno 1800 fallen die Frames ins Bodenlose, wenn ich es von DX12 auf DX11 umstelle. Das gleiche hatte ich auch, als ich bei Stellaris von DX9 auf DX11 (beta) umgestellt habe.

Der Übeltäter scheint demnach irgendetwas mit DirectX 11 zu sein. Ich habe zwar nun keinen schimmer, was ich dagegen machen kann - aber wenigstens habe ich einen Anhaltspunkt/Veredacht wo der Schuh drückt.

Viele Grüße
Frokuss

Hallo Frokuss,

wir könnten nun versuchen einige Runtime-bibliotheken zu aktualisieren.

Dazu würde ich dich bitten folgende .zip herunterzuladen:

Downloadlink: https://rebrand.ly/vcredist

Klickst du auf den Downloadlink, wirst du aufgefordert „VisualCppRedist_AIO_x86_x64_55.zip“ abzuspeichern.

Diese .zip-Datei entpackst du bitte und führst die darin enthaltene .exe aus.
Den Rest erledigt das Programm alleine und es werden unterschiedliche Visual C++ Bibliotheken heruntergeladen und installiert.

Ist das erledigt, führst du bitte mit diesem Programm fort:

Hier werden dir ebenfalls unterschiedliche Programmbibliotheken angeboten zur Installation. Nicht nur Visual C++ sondern auch allgemeine Runtime-files und auch Aktualisierungen zu DirectX.


Melde dich bitte hier, ob das dein Problem lösen konnte.

Sooooo lieber Truphoss,
ich bedanke mich recht herzlich für deine Hilfe! Ich habe den Übeltäter ermitteln können. Es war das „Citrix Workspace“ welches erhebliche Probleme verursacht hat. Nach der deinstallation von der Software, waren meine FPS zumindestens im HotS-Menü deutlichst höher als vorher. Warum auch immer lag es an der Version 2109. Ich werde nun ein paar Test machen um auch auf Nummer sicher zu gehen.

Nachtrag:
Also, es ist so wie in meinem vorherigen Post geschrieben…

Für alle, die die Citrix Workspace (2109) verwenden und Probleme mit Spielen die auf DirectX 11 laufen haben, wird es wohl an Citrix liegen. Das ganze zu beheben ist aber recht einfach.

1.) holt euch als erstes die Anleitung von eurer IT um die Citrix Workspace verwenden zu können.
2.) Über die Systemsteuerung könnte ihr Citrix Workspace deinstallieren
3.) öffnet den Microsoft store und sucht nach Citrix Workspace
4.) ladet es runter und installiert dies anschließend
5.) öffnet die Software. Nun braucht ihr eine URL damit sich Citrix mit eurem Firmendingens verbinden kann.

Falls alles geklappt hat, solltest ihr auch im Gerätemanager keine virtuelle Citrix Grafikkarte mehr finden

Viele Grüße
Frokuss