Shift + klick geht nicht mehr

Hallo liebe Leute

Ich habe seit einigen Tagen dass Problem dass Shift + Click (egal ob links oder rechtsklick) nicht mehr funktioniert. Das erste mal aufgetreten ist das Problem als ich am Berufe skillen war und ständig von bankchar auf Mainchar gewechelt bin. Auf einmal konnte ich nicht wie gewohnt die Post aus dem Briefkasten holen. Dann musste ich feststellen dass ich auch keine Items mehr im Chat verlinken kann. Das schlimmste für mich isrt aber dass ich nicht mehr in der Lage bin die Sockel zu Öffnen, d.h. wenn ich jetzt ein neues Teil bekomme kann ich das nicht mal mehr Sockeln.
Ich habe auch schon ein Ticket eröffnet, leider können mir die GMS nicht wirklich helfen, nachdem ich alle Addons und den Addonmanager gelöscht habe, sämtliche einstellungen auf Standard zurück gesetzt habe wurde mir noch geraten ich solle /console cvar_default benutzen um wirklich alles auf Standard zurück zu setzen. Voller Vorfreude habe ich dann den Befehl eingegben aber es geht immer noch nicht. Die letzte Aussage der GMs war dann dass sie mir sonst nicht mehr weiter helfen können…
Kurios finde ich dass die shift+clikc funktion auf allen meinen anderen Chars problemlos funktioniert, nur auf meinem Mainchar nicht.

Vielleicht hat ja hier jemand die zündende Idee wie man Shift+Click wieder reaktivieren kann, ich bin langsam richtig verzweifelt.

MFG Resu

4 Likes

Hast du mal bei deinen Tastatur bzw maus einstellungen geschaut?!(ingame) Villt hat sich da was verändert.

Das hatte ich auch mal, nur auf einem Char…
bis mir aufgefallen ist, dass ich wohl im Eifer des Gefechts ausversehen das Chatfenster auf „Nicht-Interaktiv machen“ gestellt hatte. Also mal versuchen Rechtsklick auf die Chat Optionen und wieder auf „Interaktiv machen“ klicken.
Hoffe das hilft

Hast Du das auch in der Battle-Net-App mal gemacht?

Da kann (konnte?) man die Spieleinstellungen zurücksetzen.

Ich hatte mal etwas Ähnliches, allerdings passt das nicht zu deiner Beschreibung, dass es nur bei einem Char ist. Aber evtl. ist das zufällig.
Bei mir war die Tastatur defekt. STRG hakte (oder war’s ALT?) und dann verhielt sich die Steuerung sehr ähnlich.

@ Yòú - Ja alles durchgeschaut, hab auch sämtliche Tastenbelegungen auf Standard zurück gesetzt
@doppelkopf - Das Chatfenster ist bereits Interaktiv
@ Jawiia - hab ich gerade ausprobiert, hilft leider auch nicht
@Ortogonn - Meine Tastatur funktionier einwandfrei

1 Like

Vor einiger Zeit hatte ein Freund ein ähnliches Problem. Auf einem einzigen Char ging plötzlich die „Freundliches Ziel anvisieren“-Funktion nicht mehr.
Auch nicht ohne Addons.
Auch nicht mit Tastenbelegung komplett löschen und neu zuweisen.
Auch nicht mit WTF-Ordner löschen.
Und auch nicht mit WoW komplett zurücksetzen. :smiley:
Das Problem bliebt auch bestehen, wenn er sich mit seinem Account an einem komplett anderen Rechner, an dem er zuvor noch nie gewesen ist, bei WoW angemeldet hat. :rofl:

Es war schlicht nicht zu beheben. Es war keine Ursache zu ermitteln.
Meine Theorie war, da ist irgendwas serverseitig mit diesem Char den Bach runter gegangen.

Es hat jedenfalls damit geendet, dass er den Char tatsächlich löschen musste, weil das Problem nicht zu beheben war, und er aus Gründen nicht ohne diese Targetfunktion spielen kann.

Um auf dein Problem zu kommen … kommt das Drücken der Shift-Taste denn noch im Spiel (bzw. bei dem betreffenden UI-Element, um präzise zu sein) an?
Kannst du beim betreffenden Char Großbuchstaben in den Chat schreiben? :stuck_out_tongue:

Was passiert, wenn du das folgende Skript ausführst, und dann Shift drückst?

/script local f = CreateFrame("Frame") local tti = 0 f:SetScript("OnUpdate", function(s,e) tti = tti + e if tti > 0.5 then tti = 0 print(IsModifierKeyDown()) end end)

Falls da dann „true“ im Chat steht - was passiert, wenn du das folgende Skript ausführst, und dann mit Shift mit der linken Maustaste auf den Button in der Mitte des Fensters klickst?
/script btn = CreateFrame("Button", nil, UIParent, "UIPanelButtonTemplate,SecureActionButtonTemplate") btn:SetPoint("CENTER") btn:SetAttribute("shift-type1", "macro") btn:SetAttribute("macrotext", "/moo")

Muhst du?

1 Like

Die Shift Taste an sich ist nicht beeinträchtigt. Grossbuchstaben funktionieren und auch die skripts funktionieren.
bei /script local f = CreateFrame(„Frame“) local tti = 0 f:SetScript(„OnUpdate“, function(s,e) tti = tti + e if tti > 0.5 then tti = 0 print(IsModifierKeyDown()) end end) kommt im Chat false false false bis ich mit Shift auf den Button drücke, dann steht da true.
Bei dem anderen Skript muuuh! ich die ganze zeit.

Kennst du jemanden mit einer WoW-Installation, bei dem du dich mal einloggen kannst, um den Char dort zu testen?

Hab ich auch schon versucht, beim kumpel am rechner ging es auch nicht

Hallo.

Versucht doch bitte einmal folgendes.

Tippe diese beiden Befehle in den Chat ein:

/console synchronizeConfig 0
/console synchronizeBindings 0

Damit schaltest du die Server-Synchronisation aus.

Setze dann die Tastatureinstellungen zurück, und stelle sicher, dass bei der Option „bei Interaktion mit Linksklick“ kein Haken gesetzt ist.

Schließe dann das Spiel einmal komplett, und starte es wieder neu.

Anschließend gibst du diese beiden Befehle in den Chat ein:

/console synchronizeConfig 1
/console synchronizeBindings 1

14 Likes

Das hat endlich geholfen

Vielen Dank!!!

Dieses Thema wurde automatisch 60 Tage nach der letzten Antwort geschlossen. Es sind keine neuen Nachrichten mehr erlaubt.