Agent update/cant uninstall battlenet

Yes so today i run up on this issue where battlenet wouldnt show my games and it said it couldnt update the agent. So i tryed allmost eveyrthing, distable antivirus, created a new microsoft acc an everthing, i tryed to uninstall battle.net in many ways but this “BLZBNTBNU00000003” comes up in different ways! I even try to just delete the folders. i allmost dmged my computer fully. So now im left with a broken battle.net file, i cant uninstall or delete or reinstall or nothing! What can i do?

2 Likes

Same, I’m completely stuck

Something similar happens to me, it says to try it when I start in administrator, which I already am, plus the updates go into a loop with each other, even putting some on pause, and you restart and sometimes it doesn’t recognize the games, they should update the battle. net or improve it, this new assistance is very bad, I haven’t been able to play retail for two days, the classic without the launcher leaves you, but the retail tells you that it is incompatible, of course because of the updates, waiting for them to do something, thanks !

It is exactly the same problem with my battlenet currently. :expressionless:

I’ve tried everything, but nothing will work.

Hello everyone,

If the regular uninstall doesn’t work, manually deleting the app should be enough. For that, please :

  1. Ensure not having any instance of the Battle.net.exe or agent.exe running (CTRL + SHIFT + esc, details tab)
  2. Delete the Battle.net folder (located by default in Program Files (x86))
  3. Delete the app cache
  4. Reinstall the app (in its default install location)
2 Likes

than you sooooo much every other method didn’t work then i discovered this one hats of to you Daernayc

1 Like

I still can’t delete the battle.net file, since I need administrator. WHICH I AM! What do I do?
Edit: I managed to fix it. You have to go into the battle.net file and delete admin first then the entire file.

Thanks very much for solution :slight_smile:

1 Like