All games install except WoW, tried all help, seems agent is crashing?

So after the Diablo IV beta I wanted to try WoW again but it seems to be stuck in a loop where it first does “Initializing ( [number]/[number) ]” and eventually reaches “Paused”, when clicking the continue button next to this it will instantly throw the error BLZBNTBNA00000006.

Note I tried install Diablo III and Warcraft III, both started the installation just fine so this is limited to just the WoW installation.

I have tried the following:

  1. Launch as admin
  2. Manually removed and/or Blizzard related folders from %temp%, %programdata%, %localappdata%, %appdata%
  3. Turned off all programs and anti virus (Malwarebytes)
  4. Restarted computer multiple times between steps
  5. Reset entire network (and waited 30 minutes), flushed DNS and disabled firewall

I also ran LogGoblin, after researching the logs I found that the agent is throwing a exception considering that on the last lines it throws “C++ Exeception: yes”

C++ Exception: yes
Exception is std::exception: yes (message: bad allocation)

Though this does not explain why for example I can’t delete my files afterwards or run the repair files, everything seems to get the launcher stuck


This forum is to provide feedback on the Battle.Net Desktop App; Blizzard rarely replies here.

A better place would be the “Classic Games Tech Support” forum. You can move this topic to that forum by:

  • Scrolling up to the very top of this topic,
  • Clicking the pencil to the right of the title,
  • Changing the category from “Feedback Discussion” to “Classic Games Tech Support”, and
  • Accepting the change by clicking on the :ballot_box_with_check: button.

Hopefully, the Blizzard Customer Support person will be able to help you with this.

1 Like

Hi pal,

i had the same problem like 2 days ago. what helped me was putting the bnet launcher into beta, after i did that the download started properly.

hope this helps

1 Like

It appears to still remain stuck, I also had to reinstall the whole client because downloading the beta got stuck at 51% but after a reinstall the beta did apply.

Also moved this thread to the correct section


Some ideas for you to try… while waiting:

Those topics are on the Americas region forums… but perhaps the cause of the issue is the same or similar. Unfortunately, you won’t be able to post in those topics unless you have a level 10 hero on America.

Good luck !