Mobile App "Something went wrong" error

Hi. I’m having issues trying to login to mobile app since they announced they’ll be moving from authenticator to mobile app. Is there anyone experiencing this and does anyone know how to solve this?

Are you still using a physical authenticator?


it happens also to me.
i have contact with support but nothing they say works.

i have tried :
delete and unlink the old authenticator to my account. deleted all cached data from my mobile , installed the new app and when it ask me to login, after some time saying still connecting, goes back to login screen with a white little screen saying " something went wrong"

i have even tried to use different networks with my mobile and still does not work.

and support has not been very supportive … with the last one being a bit ackward.

Exact same issue here when trying to move to my new pixel 7 pro phone.

Annoying to say the least.

Was able to fix it clearing all the storage used by the bnet android app and not just the cache.


This worked for me as well after restoring my new Pixel from a backup on a previous phone. Thank you!

Fixed by downloading an earlier version of the app(1.6)