Blizzard Battle.net is not updating

when i started battle.net today, it told me it had an update, but its stuck on 0% since i started it 3 hours ago, not making any progress
anyone else having this problem?

Hey there! Something may be wrong with cache files of the launcher. Can you please follow these instructions to remove it? If that doesn’t help, you can look into security applications, that also might be of use here.

I deleted the file cache like mentioned in the instructions, but the endless update is still present. Worth noting is that it dissapeard once yesterday after restarting battle.net later at night, but it’s back now.

Update: I restarted my router and it downloaded the update just fine, but later when restarting it had another update stuck on 0% again.

Hmm. Well, that tells me that the problem is connection related, rather than software. You might want to check this article and, if performing steps mentioned there didn’t give any effect, maybe contact your ISP.

I managed to fix it: I noticed the blizzard update agent did not work at all, even when i tried to uninstall battle.net. After reinstalling battle.net fully, everything worked again.

Thank you for your help either way! :slight_smile:

Interesting! Thanks for coming back to us, maybe that solution will help others :slight_smile:

I have the same problem. I tried reinstalling the launcher but it’s still stuck on zero percent. Other launchers like Epic Games can still download content as usual though.

I have the same problem. I tried reinstalling the launcher but it didn’t work i disabled my security system i tryed to run the program as administrator and it still doesn’t work. I don’t know what else to do.

FIX YOUR THINGS BLIZZ, I TRY FOR 3 about 4 HOURS AND THE SAME ERROR!

1 Like

same problem…

What other solutions are there?

Okay I found a solution. I notice that my game needed an update and I also was stuck at the game not moving past 0%. The key thing is switch your internet. If you have a phone, I suggest you use mobile hotspot for a bit to download your game to the point where it is playable. This worked for me like a charm and its the only way I found that actually worked. If you have a blue ethernet cable unplug it and use the mobile hotspot. I do believe a VPM works too but I never tried that. Hope this fixes your guys issues

Please do not bump 1 year old threads.