Cannot launch any games except for ones with 32-bit clients

Hi all

I have already mistakenly posted a similar topic on the classics games forum channel. I repost here, since it is more relevant.
My client was launching games nicely a month ago before I went on vacations. Yesterday, I noticed that none of my games were launching. After investigation, I noticed that I could launch Diablo III with the 32-bit client, which is of course not an acceptable solution. However, no matter what I have tried, I cannot find get all my other games running. They just revert back to ‘Play’ after a while.
I have done the following:

  1. Upgraded to latest nvidia driver 516.93
  2. Installed all Windows 11 updates.
  3. Cleared the %ProgramData% caches.
  4. reinstalled the client.
  5. Installed some Blizzard games on a different than the usual solid state disk.
  6. repaired installation.
  7. Removed all Razor software.

Nothing seems to work. I ran some stress tests with 3DMark and they passed with over 99.7% percent so I don’t suppose I have a hardware issue.
Finally, I have opened a ticket with Blizzard support but I have received no response.

Has anybody ever experienced something so bizarre?


EVGA / MSI Afterburner and Discord Overlay caused a lot of issues for me on Diablo III back when I was still playing it.

Since then I’ve been trying to avoid any kind of overlay garbage since it’s only eating resources and causing issues everywhere.