Cannot launch battlenet

Hello. i am having trouble opening battlenet . when i try a message pops up that says : Required application data could not be found. check your application directory and try again . also the same happens when i try to open diablo II R and diablo 3 from my desktop icon or launch please tell me what should i do. thank you

1 Like


It is possible to bypass the Battle.Net Desktop App and launch Diablo III; it is not ideal, but it can be a suitable workaround until your Battle.Net App is working again.

You will need to create a shortcut to the Diablo III app on your desktop; by default the path is:

  • C:\Program Files (x86)\Diablo III\x64\diablo III64.exe, for 64-bit
  • C:\Program Files (x86)\Diablo III\diablo III.exe, for 32-bit

Your path will differ if you installed Diablo III in another location.

Once the shortcut has been created on the desktop, you need to modify it slightly.

  • Right-click on the new Diablo III shortcut that you have now created,
  • Modify the application path by adding a space followed by “-launch” without quotes. So, for a 64-bit standard installation, it should read:
    "C:\Program Files (x86)\Diablo III\x64\Diablo III64.exe" -launch
  • Your shortcut properties should now look like this: (copy the URL to your browser)
  • Click OK to approve the changes.

Use that shortcut to launch Diablo III; you may need to change the Region (your heroes are on Europe) and put in your credentials each time you start the game.

I’m not familiar with D2R, so I cannot say whether that would also work for it… You should probably check the D2R forums.

1 Like

Hi again,

It would be useful if you could provide a bit more information on the issue.

  • when did the issue arise ? When did you launch the Battle.Net app the last time ?
  • have you installed new software just before ?
  • Do you have Blizzard games installed in the same folder as Battle.Net (C:\Program Files (x86)\ by default)
  • What drive/folder is your Battle.Net installed in ?

There was a Battle.Net Desktop App update on 17 Sept (version 13747) and some players have had problems with the App since then. There are many posts on the US Region Desktop App Tech Support forum on this. However, the error that you report is different from the error players on that forum reported. So… I am wondering if the problem is the same, or even cause by the Desktop App update.

What troubleshooting have you tried so far ? Have you tried:

including the Advanced Troubleshooting.

Have you tried to uninstall / reinstall the App ?

thank you for your reply !
Last time i played D2R was sept 17 after that i cannot even start battlenet.i have not install new software or any other change .the games and battlenet are by default at the location you described .also i have the folder version 13747 but i am not receiving error code only this message about application directory so i didnot follow any troubleshooting other to run the program as administrator but it didnot work.should i try troubleshoot despite the lack of error code?


Hi again,

Let’s see if simply uninstalling and reinstalling will solve the issue… follow the steps in , including step #5 (delete the Battle.Net tools folder). The words in blue are links to additional information and/or procedures.

After re-installation, it’s possible that the Desktop App won’t remember where the games are… you can get it to search for them in the Settings menu by using the “Scan for games” button (see my screenshot : ).

Let me know how this works.

1 Like

It worked !!Thank very much for your time and help.I open battlenet a second time just to be sure that i wont have the same problem again and its working fine now.

1 Like


Yaaaaaaaaay !! :slight_smile:

Best of luck in your games !

1 Like